ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Constantly getting Secure Connection Failed message even for sites like google.com. Need a solution for non-techie user.

  • 11 ردًا
  • 94 have this problem
  • 31120 views
  • آخر ردّ كتبه hazymsh

more options

I'm starting to frequently get "Secure Connection Failed" messages when attempting to access web sites. I even got it when trying to access goggle.com. Hard to imagine their security certification is out of date. I did a search in Support but did not see a clear, non-techie answer on how to fix this problem other than reverting to an earlier version of Firefox but do not understand how to do that. I would like to continue using Firefox but if this cannot be remedied I will be switching out of Firefox.

الحل المُختار

hazymsh said

Apparently Firefox is unable to solve this problem I will either hire someone who can solve the problem or stop using Firefox.
We are users helping other users and Firefox is the name of the web browser (third one) as the company is Mozilla.

As cor-el and jscher2000 pointed out a common cause for this is say antivirus or security software intercepting secure connections in their attempts at helping you and instead causing you to have this issue.

What Antivirus and security software do you have installed on Windows as there may be a setting you can change.

Read this answer in context 👍 2

All Replies (11)

more options

Is the date, time, and time zone set correctly in your Win7 installation?

more options

Well, the date and time display correctly for my time zone on my computer so I assume the answer is yes although I don't know how to confirm this otherwise.

more options

There is security software like Avast and Kaspersky that intercept secure connections and send their own certificate.

If you have Avast then try to disable HTTPS scanning in Avast Web Shield.


If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

more options

Apparently Firefox is unable to solve this problem I will either hire someone who can solve the problem or stop using Firefox.

more options

Hi hazymsh, if you like using Firefox, maybe you can take a few more minutes to investigate and provide some information on what you find.

When you get the error page, can you find an error code in parentheses (separated_by_underscore_characters). If you see a section of the page entitled Technical Details, expand that heading to find the error code. This will help identify the source of the problem.

Thanks.

more options

Here's what displays when there's a failed attempt to access a web site: ____________________________________ Secure Connection Failed

An error occurred during a connection to www.google.com. security library: improperly formatted DER-encoded message. (Error code: sec_error_bad_der)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

_________________________

There is no option for researching "Technical Details".

It's interesting that several sites that I have pinned as tiles on the Tabs page I can go to with no problem. If I enter the name of those same sites in the search field I get the Connection Failed message. Why can I access via tile but not via Google search?

more options

Hi hazymsh, thank you for the additional details.

"Error code: sec_error_bad_der" actually is not reported very often on this forum, particularly when accessing well-run sites with normal certificates.

Two users did report getting this error on Google with Firefox 39, but did not follow up with more information about whether they solved it or what the cause was:

I don't think using an earlier version of Firefox is going to resolve this issue.

Next questions:

(1) You mentioned getting this error frequently on websites. Can you access my test page without error, or same error code, or a different error code:

https://jeffersonscher.com/res/jstest.php

(2) Do you use any filtering software, for example, security suites that intercept secure connections (Avast, AVG, BitDefender, ESET, Kaspersky) or parental control software?

more options

الحل المُختار

hazymsh said

Apparently Firefox is unable to solve this problem I will either hire someone who can solve the problem or stop using Firefox.
We are users helping other users and Firefox is the name of the web browser (third one) as the company is Mozilla.

As cor-el and jscher2000 pointed out a common cause for this is say antivirus or security software intercepting secure connections in their attempts at helping you and instead causing you to have this issue.

What Antivirus and security software do you have installed on Windows as there may be a setting you can change.

more options

I tried your website and got the following security message:

effersonscher.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)

I had McAfee and Norton 360 running. Somehow McAfee got installed without my knowledge. I deleted the McAfee software and got the same message. Not having a problem using Internet Explorer and haven't had this problem before using FF.

more options

Hi andycruce, I will reply under your new question here: https://support.mozilla.org/questions/1087594

more options

Andycruce and Jscher2000, I'm not sure if the posts were directed to me but the problem I was having was solved by changing the settings to Avast suggested in an earlier post. Thanks for the help.