ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

bing loading on startup

  • 17 ردًا
  • 1 has this problem
  • 63 views
  • آخر ردّ كتبه bobt07

more options

This appeared about 2 weeks after installing windows 10

Have tried all the suggested cures in mozilla data base it still loads when nightly is started

All Replies (17)

more options
more options

Bing is not in my addin or plugin nor my search engine list It is set to restore my last session and when I open nightly it does restoe my last session but adds a tab with Bing as the search engine

more options

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see:

You can open the about:config page via the location/address bar and search for prefs that refer to bing. You can reset user set (bold) prefs via the right-click context menu to the default value.

more options

Tried the first two but still same result bing tab loaded about:config Found 3 lines modified there value to blank (it would not let me change to anything else) closed and restarted Nightly bing tab loaded Checked about:config the 3 bing lines were not there

more options

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

You can use this button to go to the current Firefox profile folder:

Firefox will rebuild the search.json file from the default built-in search engines that come with Firefox and the searchplugins folder in the Firefox profile folder.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Does this solution help? https://support.mozilla.org/en-US/questions/959280

I could find search hits for Bing hijacking new tabs, but nothing about it popping up an extra tab on Firefox start with "Show my windows and tabs from last time" selected. Maybe it's just a new tab that gets opened for some reason, and has Bing on it?

I have a suspicion the extra tab may be due to something akin to this: http://ask-leo.com/how_do_i_stop_firefox_from_opening_with_two_tabs.html. Try to manually set Firefox to open just one tab on start (about:blank or whatever), restart, and then apply the previous setting "Show my windows and tabs from last time" and see if that fixes it (i.e. you reset the setting).

Failing that, it might be time for a new profile as suggested above. You can also use the Refresh function in new Firefox: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings.

more options

When I tried to run the profile manager all that happened was nightly open normally also with the bing tab even tried typing the full address The -p option does not appear to be working I then started in safe mode and it started without the bing tab Then disable the 5 addon that I have but it started with the bing tab Tried to delete the addons but that option does not appear to be there

more options

This is a screen shot of my add ons

more options

Yep, shouldn't be any of those plugins at fault. I don't think the Silverlight installer prompts you to install Bing guff, but you could double-check that.

What about your Extensions? If Safe Mode doesn't produce the tab, it is increasingly likely that an Extension add-on is doing something funny.

Modified by Phoxuponyou

more options

The screenshot shows the plugins page and not the extensions page. The installed extensions appear under the Extensions tab (the second tab in the menu bar on the left).

more options

I do not have any extensions installed

more options

It is possible that extensions are hidden and do not show in the extensions manager, so you cloud still give starting Firefox in Safe Mode a try.


You can open the about:config page via the location/address bar and search for prefs that refer to bing. You can reset user set (bold) prefs via the right-click context menu to the default value.

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

more options

I found the following in about:config

browser,search.hiddenOneOffs user set string Bing

modified the value to blank that was all it would let me do

restarted nightly and the bing tab loaded again after all the other tabs from my previous session

checked above:config again it was still set at

browser,search.hiddenOneOffs user set string

Checked the short cut properties there was nothing appended to the firefox.exe

Do you know why when I appended the -p to firefox.exe that the profile manager did not start only the normal nightly session Also tried appending ? and a normal session started Tried these with administrator privilege

more options

You're on Windows 10, but Windows 8 (or some version or installer thereof) apparently has a "feature" for opening Bing tabs.

See http://www.cnet.com/forums/discussions/bing-pop-ups-600476/, "I am getting whole screen alarmist pop-ups via IE though I use Nightly as my browser." The symptoms don't match yours exactly (no pop-ups, right?), but might be something to check, in case it's not funky stuff you've installed on purpose or by accident (like http://malwaretips.com/blogs/remove-www-search-net-virus/, for example).

Solution for this issue: "[D]isable it via setting following registry entry from 1 to 0: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing".

Discussion (long): http://answers.microsoft.com/en-us/ie/forum/ie10-windows_8/windows-8-goes-to-bing-by-itself-all-the-time/386e9a25-8149-4ee6-84b4-65332022c2a7.

Modified by Phoxuponyou

more options

Still working through the last suggestion The same problem also happens with IE loaded and set google as the default bing still loads on starting a new session I have also noticed after updating Nightly and doing the restart the bing tab does not load

more options

When I click on the "This doesn't solve my problem" link in the email reply it also loads a bing tab This is the only email link that seems to load a bing tab

See the screen dumps above

more options

The bing tab loads even after rebooting in Safe Mode If I start nightly as an administrator the bing tab does not load