ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

where is an exception I created for an 'untrusted' website stored in my PC, so that I can now remove it?

  • 5 ردود
  • 2 have this problem
  • 1483 views
  • آخر ردّ كتبه kevindu

more options

My PC's time and date were incorrect and were the cause of the site presenting as untrusted. Since I then unwittingly entered it as an exception, I've now decided I want to delete the exception, but don't have any idea how to do so. My browser is Firefox, and my OS is Vista. I would appreciate any help. Thank you, kevindu.

الحل المُختار

Did you look for this exception under the servers tab in the Certificate Manager?

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

You can use this button to go to the current Firefox profile folder:

Read this answer in context 👍 1

All Replies (5)

more options

hi, go to the firefox menu ≡ > help ? > troubleshooting information, click on profile folder/show folder and close all firefox windows afterwards. a windows explorer window should open up - in there rename or delete the file named cert8.db - it contains all your customizations to the certificate store & will be regenerated again the next time you launch the browser.

more options

Hi Philipp, Thanks for the prompt reply, but unfortunately this does not solve my problem. I should have made it clear that I want to permanently remove the exception, whereas your suggested solution would regenerate it again on the next start-up. Also, although you say 'a windows explorer window should open up,' it did not do so for me. Furthermore, I now notice that when I access the 'suspect' website, there's a reference to the fact that I have designated it as an exception - which I don't want it to be! Does this help at all? Many thanks anyhow. kevindu.

more options

الحل المُختار

Did you look for this exception under the servers tab in the Certificate Manager?

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

You can use this button to go to the current Firefox profile folder:

more options

kevindu said

I now notice that when I access the 'suspect' website, there's a reference to the fact that I have designated it as an exception - which I don't want it to be!

Where is Firefox indicating that you made an exception for the site?

All the previous replies relate to getting an Untrusted Connection page, expanding the section called "I understand the risks" and using the "Add Exception" button to tell Firefox to trust the site's SSL certificate even though Firefox would not normally trust it.

If you did something different, then that information may well be stored in a different dialog/file than a certificate exception.

Modified by jscher2000

more options

Many thanks to philipp. jscher2000, and cor-el for jointly directing me down the right path to enable me to solve my problem. Thanks again!

Regards, kevindu

Modified by kevindu