ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 40 final is not Windows 10 compatible

  • 15 ردًا
  • 8 have this problem
  • 2569 views
  • آخر ردّ كتبه jsljustin

more options

Are you using NVIDIA? [[Hardware acceleration in Windows 10 is not working - NVIDIA|https://support.mozilla.org/en-US/questions/1077259]]

It's because they disabled hardware acceleration thus using more processing power.

https://support.mozilla.org/en-US/questions/1077356

If this is the case, why is Mozilla misleading many Windows 10 Firefox users with an upgrade to FF 40.0, selling it as ensuring a smooth transition for anyone that has upgraded their system to Windows 10. It's a blatant, misleading untruth and Mozilla should remove the text from their FF 40.0 upgrade spiel.

Why not upgrade to FF 40? It'll ensure that many Windows 10 users eith NVidia will experience extremely high CPU ratings and a complete operating system slowdown. That is the fact of the matter. Mozilla is misleading Windows 10 users with NVidia cards regarding this upgrade to FF 40. It is NOT fully Windows 10 compatible. Mozilla should stop trying to sell it as though it is.

The attached screenshot illustrates he devastating effect upgrading to FF 40 can have on cpu rate when trying to play any HTML5 content. 1080p playback being the worst culprit. Windows 10 compatible? Yeh, right!

Attached screenshots

Modified by HPDeskjet

الحل المُختار

Let us rejoice :-)

With the release of FF 40.0.2 this issue is now solved, when used in conjunction with the latest Windows 10 355.60 drivers from Nvidia.

I think we can consider this solved.

Read this answer in context 👍 0

All Replies (15)

more options

Sorry, I don't see how Firefox 40 getting more Windows 10 "support" than earlier versions of Firefox had is misleading users."Support" isn't a fixed or quantifiable status, it's an on going process.

Considering that Windows 10 was Released on July 29, 2015, Microsoft was making changes / refinements to Windows 10 long after Firefox 40 was already in the pipeline to Release. Firefox 40 was more compatible than Firefox 39 was, and Firefox 41 will be more compatible than Firefox 40 is now; and so on.

Also, Nvida is probably working on graphics drivers as their part of providing Windows 10 compatibility, or they should be. When a new operating system version is released everyone is working on their part of the compatibility equation.

Why upgrade to FF 40? For greater compatibility than was in Firefox 39 and for the security fixes. https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox/#firefox40

more options

While I agree with your points, it strikes me as astonishing that NVidia and other manufacturers have not sorted out drivers for Windows 10. How long has the Insider Programme been running for 10? It's been the same all down the line with every new release from Microsoft, with Vista being the prime example of no drivers, incompatible programmes etc being ready.

With Windows 10 it's the same with major drivers. NVidia dragging its heels as usual, with Creative normally coming a close second.

I'll use Opera in the meantime. I did stop using Opera as default 4 years ago, after Opera 12 was no longer supported. That's when I switched to Firefox as my default.

Video not working correctly, thanks to NVidia, means a temporary change of default browser. Once it's all sorted FF will be back as my default. I'll keep an eye out for new drivers from NVidia.

more options

In case you are encountering this problem primarily on YouTube, I wonder whether one of the extensions to force YouTube to serve the Flash player would work around this problem?

more options

It's primariy with youtube.com. I'll try the extensions as a temporary fix. Once the HTML5 video playback is sorted I'll stop using them.

Thanks for the advice and the feedback.

more options

In FF 40.0, flash cpu usage, when viewing 1080p HD on youtube.com, is back to an average of nearly zero. Flash at around 9-10%.

Modified by HPDeskjet

more options

I see that Nvidia have released official Windows 10 drivers today http://www.geforce.co.uk/drivers/results/89369/nvidiaupdate


I'm installing them now to see if this solves the problem.

more options

Well, the new Windows 10 355.60 drivers from Nvidia, which were released today, have done nothing to fix HTML5 playback and the totally out-of-order high CPU in FF. 83% cpu from FF, these 355.60 drivers are worse than the last.

I can't stick with FF and this amateur nonsense from Nvidia and their drivers. What is the problem now with hardware acceleration? It's a pity Nvidia are so hopeless at times.

Modified by HPDeskjet

more options

One reason I used an ATI/AMD video card when I built my new PC back in April.

more options

الحل المُختار

Let us rejoice :-)

With the release of FF 40.0.2 this issue is now solved, when used in conjunction with the latest Windows 10 355.60 drivers from Nvidia.

I think we can consider this solved.

more options

Following everything in this thread I still had issues with FF 40.0.2 running between 70-100% on my Windows 10 64-bit system with NVidia GT 730 card. It wasn't until I stumbled upon a thread in tenforums (http://www.tenforums.com/graphic-cards/10513-latest-nvidia-drivers-keep-crashing-recovering-post318276.html#post318276) that I was able to drastically reduce the amount of CPU that FF was hogging.

Taking the suggestion of running DDU (display driver uninstaller) and then doing a clean install of the 64-bit Win10 355.60 driver did the trick for me (and DDU automatically disables driver updates so no worries of a Microsoft driver update). Currently with 9 tabs open (two of which are generally heavily flash-dependent) my CPU is hovering around 17.5% +/- 2.5%. hat is a significant difference in performance. Until NVidia comes up with a new driver that completely fixes the issue, this will work for now.

more options

The problem is not fixed, so fine if you find you don't have an issue, but don't just state publicly that it is fixed when you don't know. It's fixed for you, is what you need to say.

I still get high CPU usage, it is normally spikes, but I am noticing that text entry is laggy, or to the point where I am typing, and 20 seconds later the text appears, or like today twice my entire system froze, and I had to terminate firefox, as the CPU usage was high and constant. I am finding that the whole browsing experience is now sluggish and not smooth at all.

Windows 10, Nvidia GTX970, Haswell 3.9GHz i7, 8GB RAM, samsung 250GB SSD.

more options

Hi jsljustin, you are correct that when a person marks a solution for THEIR problem that does not mean it is a solution for YOUR problem.

Did you see the suggestion above your post: https://support.mozilla.org/questions/1077384#answer-772709

If that doesn't help, I encourage you to start a new question with your system details. You can do that here:

https://support.mozilla.org/questions/new/desktop/fix-problems

Articles will be suggested as you enter your question, you can ignore those if they don't look helpful and keep scrolling down to continue with the form.

more options

Yes you are right jscher2000 - sorry, just frustrated with system lockups when running firefox.

The above post / suggestion didn't fix my issue. What I found by scouring the web was that it appears mozilla has blocked or blacklisted some hardware acceleration aspects of firefox for nvidia GPU users. I ended up easing the huge cpu spikes (and browser and system lockups and freezes) by going to about:config and manually changing some of the GPU hardware acceleration settings. Now, whilst I still get higher-than-normal CPU usage with firefox, at least it isn't freezing or crashing.

As I understand it, some Nvidia GPU users were having problems with display in Firefox, and Mozilla changed hardware acceleration for ALL nvidia firefox users, but the problem is that Firefox was running just fine for me on Windows 10 initially. So they fixed some problem for some, but they ended up causing me and many others major problems, whereas before there were none.

more options

Hi jsljustin, if you think it would help other similarly situated users, do you want to post the settings changes you made? You can right-click > Copy the preference and when you paste it, it will show both the name and the current value.

more options

Hi jscher2000,

I was told to do the following - reset the below back to "true" if set to "false".

gfx.direct2d.force-enabled;true

Go into about:config in firefox, then search for "gfx.direct2d.force-enabled" (minus the "").

and then set it to true if it is false - only if you are getting high CPU usage with firefox.

I am not 100% on this, but since following those instructions, I have not had high CPU spikes / usage. CPU usage of firefox was up to 25-40% before, and now it rarely gets above 10% and even then only for a second or two.

Hope this helps. Justin

Modified by jsljustin