ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

There is no red X to close Firefox.

  • 14 ردًا
  • 8 have this problem
  • 1472 views
  • آخر ردّ كتبه mugrug19

more options

Downloaded 40.0. What happened to the red X to close the browser. There are no minimize and maximize buttons. I know it's a beta version, but how did they mess that up?

الحل المُختار

I did a refresh of Firefox, problem solved.

Read this answer in context 👍 2

All Replies (14)

more options

Hmm, Firefox 40 was supposed to adapt better to the new flat look of Windows 10. (Also, the version released today is the final, non-beta version.)

If all three of the title bar buttons are missing, is there anything in their place, like a black rectangle, which can indicate graphics incompatibility?

If there's nothing there, could you check that Firefox didn't launch in Full Screen mode? You can use the F11 key to switch between full screen and normal views.

more options

Thank you for the reply. All three title bars are missing. There is nothing in there place. I'm not in full screen mode. If I right click up top I can close, maximize and minimize. I assume you have 40.0? Do you have the three title bars?

more options

jscher2000 said

Hmm, Firefox 40 was supposed to adapt better to the new flat look of Windows 10. (Also, the version released today is the final, non-beta version.) If all three of the title bar buttons are missing, is there anything in their place, like a black rectangle, which can indicate graphics incompatibility? If there's nothing there, could you check that Firefox didn't launch in Full Screen mode? You can use the F11 key to switch between full screen and normal views.
more options

If I go to full screen, I see the X, it's not red and the minimize, and maximize buttons. The only problem is they are on the tabs bar, and look weird.

more options

I have Firefox 40 on Windows 7 and nothing is weird, I have the usual 3 buttons on the far right end of the title (top) bar. In Windows 7 I've never seen a right-click menu with close, minimize, maximize/restore, although that has long been available using Alt+Spacebar. Hopefully someone more familiar with Windows 10 can chime in about what's going on.

more options

jscher2000 said

I have Firefox 40 on Windows 7 and nothing is weird, I have the usual 3 buttons on the far right end of the title (top) bar. In Windows 7 I've never seen a right-click menu with close, minimize, maximize/restore, although that has long been available using Alt+Spacebar. Hopefully someone more familiar with Windows 10 can chime in about what's going on.
more options

I am running Windows 10, upgrade from 8.1. Firefox 39.03 ran fine. I'm sure it will get solved. Thanks.

more options

mugrug19 said

If I go to full screen, I see the X, it's not red and the minimize, and maximize buttons. The only problem is they are on the tabs bar, and look weird.

In a maximized window, you can hide the title bar and menu bar and then the tabs slide up into empty space in the title bar. So in that case, you'll have the 3 buttons at the right end.

But in Full Screen view, the whole tab bar, main toolbar, bookmarks toolbar, etc., usually slides up out of view. So something is a little off on your system...

Could you check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste fulls and pause while the list is filtered

(3) If the browser.fullscreen.autohide preference is bolded and "user set" to false, double-click it to restore the default value of true -- this controls whether the toolbars slide up and hide in full screen view

more options

jscher2000 said

mugrug19 said
If I go to full screen, I see the X, it's not red and the minimize, and maximize buttons. The only problem is they are on the tabs bar, and look weird.

In a maximized window, you can hide the title bar and menu bar and then the tabs slide up into empty space in the title bar. So in that case, you'll have the 3 buttons at the right end.

But in Full Screen view, the whole tab bar, main toolbar, bookmarks toolbar, etc., usually slides up out of view. So something is a little off on your system...

Could you check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste fulls and pause while the list is filtered

(3) If the browser.fullscreen.autohide preference is bolded and "user set" to false, double-click it to restore the default value of true -- this controls whether the toolbars slide up and hide in full screen view

more options

browser.fullscreen.autohide, is not bolded and is set to true. In full screen it does slide up out of view. If I move my cursor up it come out of full screen that is when I see the X, min, and max. When I hit F11 to go back to regular screen, I lose X, Min and Max. It's crazy.

more options

الحل المُختار

I did a refresh of Firefox, problem solved.

more options

mugrug19 said

Downloaded 40.0. What happened to the red X to close the browser. There are no minimize and maximize buttons. I know it's a beta version, but how did they mess that up?

The suggestion was made in this forum to refresh Firefox. That person said that doing so fixed it for him/her; but when I tried it, there was no change. Therefore, unless you want to go through the hassle of reinstalling all your add-ons, and redoing all of your settings, I would not recommend it. There are two workarounds, however: First, although the buttons are not there, I have found that if one right-clicks on the spot where they should be, a menu with the same choices that the buttons offer appears. The other choice, which will allow you to close the window, but not minimize or maximize it, is to right-click on the Firefox icon in your taskbar. A menu will appear that includes the option <CLOSE WINDOW>.

more options

David said

mugrug19 said
Downloaded 40.0. What happened to the red X to close the browser. There are no minimize and maximize buttons. I know it's a beta version, but how did they mess that up?

The suggestion was made in this forum to refresh Firefox. That person said that doing so fixed it for him/her; but when I tried it, there was no change. Therefore, unless you want to go through the hassle of reinstalling all your add-ons, and redoing all of your settings, I would not recommend it. There are two workarounds, however: First, although the buttons are not there, I have found that if one right-clicks on the spot where they should be, a menu with the same choices that the buttons offer appears. The other choice, which will allow you to close the window, but not minimize or maximize it, is to right-click on the Firefox icon in your taskbar. A menu will appear that includes the option <CLOSE WINDOW>.

more options

Refreshed worked for me. I'm sorry it did not work for you. I hope you get your problem fixed.