ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

What do I do if "Recently Closed Windows" shows nothing?

  • 5 ردود
  • 18 have this problem
  • 654 views
  • آخر ردّ كتبه warriorjames99

more options

Today I ran into a very unusual problem. I was surfing the web and right-clicked a url and told it to open in a new tab. Instead of showing "Connecting" it showed a tab that was completely blank I Right-clicked a few more times and I duplicated to process. What's more, the X to close the tabs was gone as well. Not sure of what to do I simply closed the window entirely. I had a second window open, so I still had Firefox going. When I hovered over "Recently Closed Tabs" it showed the closed tabs that were from the second window in the box that pops out. I thought "Ok, everything seems fine." I then over "Recently Closed Windows" and absolutely nothing popped out. No box or anything. I tried restarting, but got the same result. I even tried opening a new window and going to something in the favorites and closed the window. Still nothing.

This has me very confused.

I'm using Firefox 39.0 on Ubuntu 14.04.2

الحل المُختار

After a few quits and launches of Firefox it is suddenly working again. Very strange.

Read this answer in context 👍 0

All Replies (5)

more options

Could you confirm that Firefox is not running in automatic private browsing mode? You can check that here:

"3-bar" menu button (or Edit menu) > Preferences > Privacy

If the selector is set to "Firefox will: Never remember history" please change it to "Firefox will: Use custom settings for history" and uncheck the box for automatic private browsing.

Assuming that isn't the problem, could you check to see whether some of your session history settings might have gotten zeroed out. In particular:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) If the browser.sessionstore.max_windows_undo preference has been modified from its default value of 3, you can double-click and edit it to the desired number of closed windows to remember

Anything helpful so far?

more options

I wasn't in a private window. I'd know since I've pulled "Restore Previous Session" many times and it was right there under "Recently Closed Windows".

In preference it is set to "Remember History".

And browser.sessionstore.max_windows_undo is indeed set to 3.

So that doesn't seem like the problem.

Modified by warriorjames99

more options

الحل المُختار

After a few quits and launches of Firefox it is suddenly working again. Very strange.

more options

Did this also not work if you closed a window in the current session?

You can try to prevent websites from disabling some toolbars and other features and toggle dom.disable_window_open_feature.* prefs to true on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

I can close a window in the session I'm in and open it up through "Recently Closed Windows" no problem. Also, when restoring a session (like what I've done a few times now), all the windows that I closed in that session are still available to be opened again.