Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I get a untrusted connection message on all websites

  • 10 replies
  • 31 have this problem
  • 37301 views
  • آخر ردّ كتبه lith1um

more options

I get the "Connection is Untrusted" (( website) uses an invalid security certificate) message on all pages I try to visit.

Chosen solution

thanks for following up. unfortunately the do_not_trust certificates might be a sign of unwanted software present on your pc that is intercepting secure network traffic. please go into the system control panel and uninstall programs like BrowserSafeguard, BrowserSafe, SafeGuard or other software that sounds suspicious and didn't get installed by you intentionally. reference: https://support.mozilla.org/en-US/questions/982532#answer-520145

afterwards, run a full scan of your system with different security tools like the free version of malwarebytes & adwcleaner.

Troubleshoot Firefox issues caused by malware

Read this answer in context 👍 4

All Replies (10)

more options

hello, first please make sure that the date, time & timezone are set correctly on your system. if this doesn't solve the issue (or it is already set properly), a possible solution depends on different factors:

  • what is the error code shown under technical details on the error page?

in case the error code equals sec_error_unknown_issuer, please attempt to add an exception on the bottom of the error page in order to inspect the certificate like it is shown on the screenshot attached:

  • which issuer information does the certificate contain?

please report back with those two pieces of information. thank you!

more options

The error code is sec_error_unknown_issuer. I m unable to view your screen shot to find issuer information. I did find issued by "DO_NOT_TRUST_FiddlerRoot"

more options

Chosen Solution

thanks for following up. unfortunately the do_not_trust certificates might be a sign of unwanted software present on your pc that is intercepting secure network traffic. please go into the system control panel and uninstall programs like BrowserSafeguard, BrowserSafe, SafeGuard or other software that sounds suspicious and didn't get installed by you intentionally. reference: https://support.mozilla.org/en-US/questions/982532#answer-520145

afterwards, run a full scan of your system with different security tools like the free version of malwarebytes & adwcleaner.

Troubleshoot Firefox issues caused by malware

Modified by philipp

more options

What is the problem with Firefox and the untrusted websites. It was working fine then I clicked on an update now just about every website is untrusted. I think you guys are going too far - perfect security id not using a web browser. That won't work. You have to know you break things on weekends when your servers get corrupted or somebody is doing maintenance.

more options

Hi edspyhill09

Did you check the issuer of the certificate(s)?

On Windows there is a lot of (security) software that decides to intercept and monitor all internet traffic and in order to do that they place themselves in the connection. To be able to monitor a secure connection they have to build a two way connection between themselves and Firefox and between themselves and the internet server (i.e. act as a man-in-the-middle- MITM). Firefox have nothing to with such an intrusion and can't do anything apart from warning you. It is up to you to decide whether you accept this intrusion and trust this software as it can see everything you send over a secure connection.

The Risks of SSL Inspection: https://insights.sei.cmu.edu/cert/2015/03/the-risks-of-ssl-inspection.html


If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer.

more options

Hi edspyhill09, it's not normal to get untrusted connection errors on multiple sites in Firefox, and updates do not change that. It's usually a question of Firefox not being set up to work with your security software. Or a new malware infection.

Many users see a message during an update indicating that Firefox is starting slowly and you can speed it up by restoring some default settings. If you click that button, Firefox performs a Refresh. The telltale sign is an Old Firefox Data folder on your desktop. Do you see anything like that?

If you have an Old Firefox Data folder, check inside for a semi-randomly-named folder with recently updated files. If your Firefox stopped trusting your security software, it may be convenient to copy the cert8.db file from that folder to your current Firefox settings (profile) folder to restore trust. Details to be provided if relevant.

more options

I started getting untrusted connections after an update was applied to Firefox. The problem will go away tomorrow on its own. It's why I use Firefox less and less. Close the ticket.

more options

edspyhill09 said

I started getting untrusted connections after an update was applied to Firefox. The problem will go away tomorrow on its own. It's why I use Firefox less and less. Close the ticket.

So this problem resolves itself when you shut down Windows and start it up again? That's interesting, perhaps your security software checks for browsers at startup.

By the way, this is not your "ticket" to close, you posted in someone else's thread. If you want to start a new question, there's a link at the top of every page.

more options

No. I cleared the history and still got errors. I rebooted the PC and still got errors. The problem seems to resolve itself magically. It is why I use Firefox less and less. The most secure software is the software that cannot be used. I have uninstalled Firefox.

more options

I have had the same issue before, i tried every possible fix including exporting the root CA from Chrome and importing in Firefox but it didnt work.

Finally i downloaded ADWCleaner and it detected some strange entries in the registry that looked like proxy.data & proxy.xxx etc.

After running the cleanup process and rebooting the PC, the problem has been resolved!!