ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lost ability to bookmark pages after recent updates

  • 19 ردًا
  • 5 have this problem
  • 926 views
  • آخر ردّ كتبه jscher2000

more options

Firefox was working great until recent updates of version 39.

I have now lost my ability to bookmark a page. When I click the star icon as I always had, the star turns bright blue and gives the appearance that the bookmark is being transferred--or "thrown into" -- the bookmark icon. But the page never appears anywhere in my bookmarks.

Before when I clicked the star, I always got a box that would let me edit the name I wanted for the bookmark name, and the different bookmark menu locations that I could choose from as to where I wanted the bookmark to go. Now I don't get any box.

I know this has to be a result of the recent update changes and not something in my computer because I never had that simulation of "throwing" the bookmark before. Or the bright blue star.

الحل المُختار

OK, try clicking on Restore Defaults as shown in - Customize Firefox controls, buttons and toolbars.

If that doesn't do it try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If still no joy, try the Refresh feature (called "Reset" in older Firefox versions) which can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

Read this answer in context 👍 1

All Replies (19)

more options

Hi, if you click on the star once, the bookmark will go into Unsorted Bookmarks. However if you wish the bookmark to go to a different destination, you should click on the star twice, then in the dialog box, use the upper, downward pointing arrow on the far right, to select a destination > Done.

The following may also be of use - Bookmarks in Firefox.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options
more options

Scribe said

Hi, if you click on the star once, the bookmark will go into Unsorted Bookmarks. However if you wish the bookmark to go to a different destination, you should click on the star twice, then in the dialog box, use the upper, downward pointing arrow on the far right, to select a destination > Done. The following may also be of use - Bookmarks in Firefox. If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

It doesn't matter if I click once or twice, I don't get the dialog box anymore.

This is what has changed. By clicking twice before, I used to get the box. Now I get what I described in my post. And no bookmark saved anywhere.

more options

الحل المُختار

OK, try clicking on Restore Defaults as shown in - Customize Firefox controls, buttons and toolbars.

If that doesn't do it try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If still no joy, try the Refresh feature (called "Reset" in older Firefox versions) which can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

Thanks for your efforts.

Are you saying that something my computer did that caused this to happen and not a Firefox glitch in one of the most recent updates?

All I do is allow the download each time there is the next new version and at some time immediately after one of those downloads, this started to happen. I don't let them download automatically but I always manually give them permission.

I'm not that much of a tech wizard and to go through all these steps and then lose my extensions very possibly besides, it may be more practical for me to just use another browser to store the page address as a bookmark.

But this sure is frustrating.

more options
more options

I wouldn't know what I'd be looking for. And truthfully, I'm just not adept enough to narrow down the problem. To say nothing about what I might mess up or make worse than it is now.

As of now, the only function I don't have is making a bookmark of a page I want.

That black and white bookmark icon never turned blue before or got BIGGER. This is what happens now when I click it. Then it acts as if it's "throwing that star into the icon '''next to it' that says "show your bookmarks" when you hover the cursor over it.

I have to just hope that a new update corrects the problem I didn't have until I allowed an update.

more options

Does the star gets a blue highlight?

In that case you can click the star another time and move the bookmark from the unsorted folder to another folder.

more options

Hi rj343, the add-on that cor-el linked to, Places Maintenance, lets you run a number of tasks to clean up the database that stores your bookmarks and history. I haven't tried it myself, but I think you just click some boxes and then a button to run it.

When you are on a page with the star "lit up" in blue, does pressing Ctrl+d call up the Edit Bookmark dialog?

Or alternately if you bookmark a page using one of these methods, can you select the destination:

  • Ctrl+d
  • right-click the page > star icon on the context menu
  • (menu bar) Bookmarks > Bookmark This Page
more options

Hi guys,

I really did my best to try to show you what I see.

Clicking or double clicking, this is what happens. The dotted red line does not appear, but this indicates the direction of how that star appears to be being "thrown." It moves from the left icon to the right and the star is bigger as I've shown in the image.

I can click a hundred times and each time this is what I get. And the bookmark does not then appear in ANY menu. It's as if I never clicked the star.

I also don't get the dialogue box I used to get either no matter what I do.

more options

jscher2000 said

When you are on a page with the star "lit up" in blue, does pressing Ctrl+d call up the Edit Bookmark dialog?

No... if the star is blue on a page, pressing control D, does nothing.

Right clicking on a page, doesn't result in any way to save the bookmark either.

The only thing I can do...I have X-notifier extension and for some reason, after right clicking I have that option to save the bookmark in the X-notifier folder. And it does go into that folder.

more options

Hmmm, well I found something.

I started Firefox in safe mode as Scribe suggested. And the bookmark works! I also get the dialogue box by pressing Control D.

So what does this mean?

more options

Found it !!

Following the great helpful links by Scribe, I fixed the problem.

I had the extension IE tab which switches a page to Internet Explorer and for certain things this is helpful.

But apparently I had a very old version and when Firefox updated recently to the versions 39, this disabled bookmarks. No one would know who has this.

There is a new version of IE tab called IE Tab 2. I installed this and bookmarks are working great again.

Thanks to all of you who were helping. The internet sure is a great thing.

MARKED SOLVED

more options

p.s. I also had this issue (FF40.0.2, on Windows 7), after upgrading from FF38.

My issue was also related to a plugin (tree-style-tab) - https://github.com/piroor/treestyletab/issues/920

 - disabling the plugin resolves the issue.

So, the behaviour appears due to some plugins, but seems related to the upgrade. I'm happy to try to diagnose which part of the update may be related if someone can point me in the right direction.

more options

Hi shearer12345, this is the most relevant list I've seen for investigating further: https://blog.mozilla.org/addons/2015/06/18/compatibility-for-firefox-40/

more options

rj343 said

Scribe said
Hi, if you click on the star once, the bookmark will go into Unsorted Bookmarks. However if you wish the bookmark to go to a different destination, you should click on the star twice, then in the dialog box, use the upper, downward pointing arrow on the far right, to select a destination > Done. The following may also be of use - Bookmarks in Firefox. If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

It doesn't matter if I click once or twice, I don't get the dialog box anymore.

This is what has changed. By clicking twice before, I used to get the box. Now I get what I described in my post. And no bookmark saved anywhere.

I have the same problem--it doesn't matter if I click once or twice, or use the context menu. I don't get the dialog box most of the time. Sometimes it works, sometimes it doesn't!

more options

Hi GinaPA, I don't know whether you read through this whole thread, but the most common reason for this problem is an extension such as IE Tab, IE Tab 2, or Tree Style Tab. Tab Mix Plus also can cause bookmarking issues.

You can review your extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then you can review the list on the right. If you have IE Tab extensions, go ahead and disable those. If you need advice on the others, let us know what you have.

more options

jscher2000 said

Hi GinaPA, I don't know whether you read through this whole thread, but the most common reason for this problem is an extension such as IE Tab, IE Tab 2, or Tree Style Tab. Tab Mix Plus also can cause bookmarking issues. You can review your extensions on the Add-ons page. Either:
  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Extensions. Then you can review the list on the right. If you have IE Tab extensions, go ahead and disable those. If you need advice on the others, let us know what you have.

Thank you..I did see the IE Tab extension help that was offered and upgraded that, but I missed the Tab Mix Plus issue (which I also use). Thanks for the fast response.

more options

GinaPA said

Thank you..I did see the IE Tab extension help that was offered and upgraded that, but I missed the Tab Mix Plus issue (which I also use). Thanks for the fast response.

My bad, I thought this was one of the Firefox 40 threads, but it was a Firefox 39 thread. The fixed version of TMP is awaiting approval if you want to grab it now. If you don't need it badly, then hopefully the official release will occur in a few days.

https://addons.mozilla.org/firefox/addon/tab-mix-plus/versions/