X
Tap here to go to the mobile version of the site.

منتدى الدعم

How can I get Firefox to not reload pages when I hit "back"?

Posted

I do CSS work within a website, and sometimes when I'm doing so, I accidentally click out of the text box and hit "back." This wasn't a problem before, because Firefox would keep everything how it was when I hit forward. BUT anymore, everything reloads, and it erases everything I had typed up, and makes me extremely irritated. HOW can I get it to not do this? I'm pretty sure Chrome doesn't do this, so if it means switching, I will, because this is really a huge burden.

Re-summary.

I'm typing things, accidentally hit back, hit forward, and everything is erased because the page reloads. I would like it to not do this, as it used to do.

I do CSS work within a website, and sometimes when I'm doing so, I accidentally click out of the text box and hit "back." This wasn't a problem before, because Firefox would keep everything how it was when I hit forward. BUT anymore, everything reloads, and it erases everything I had typed up, and makes me extremely irritated. HOW can I get it to not do this? I'm pretty sure Chrome doesn't do this, so if it means switching, I will, because this is really a huge burden. Re-summary. I'm typing things, accidentally hit back, hit forward, and everything is erased because the page reloads. I would like it to not do this, as it used to do.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 18.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

guigs 1072 solutions 11697 answers

Hi erealia, This sounds extremely annoying and it has happened to me as well. Make sure that the setting for Firefox to save form data is still on:

Second, as a precaution try Lazarus, a form remeberer addon.

Sorry for the frustration I hope that this add on does you wonders.

Hi erealia, This sounds extremely annoying and it has happened to me as well. Make sure that the setting for Firefox to save form data is still on: *[[Control whether Firefox automatically fills in forms]] Second, as a precaution try Lazarus, a form remeberer addon. *[https://addons.mozilla.org/en-US/firefox/addon/lazarus-form-recovery/?src=search] Sorry for the frustration I hope that this add on does you wonders.
cor-el
  • Top 10 Contributor
  • Moderator
17587 solutions 159102 answers

This can happen if the page isn't in the disk cache.

Is the disk cache enabled and working if you check that on the about:cache page?

You can open about: pages via the location/address bar.

This can happen if the page isn't in the disk cache. Is the disk cache enabled and working if you check that on the about:cache page? You can open <b>about:</b> pages via the location/address bar.