ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disabling hardware acceleration also screws up font anti-aliasing

  • 1 (رد واحد)
  • 6 have this problem
  • 54 views
  • آخر ردّ كتبه impy

more options

As in title.

First screenshot shows what happens with hardware acceleration enabled, which looks better, second screenshot shows how it looks aliased with acceleration disabled, with the stroke missing in certain places on very light fonts.

However, when hardware acceleration is enabled, if I open very large images or lots of inline images at a time, the browser window will flash white, all tabs will lose their favicons, and the browser must be restarted. For this reason I'm looking to keep hardware acceleration disabled, but use it (or its method) for rendering fonts only, if such a thing is possible. Alternatively I'd like a fix for hardware acceleration causing such behavior, although that seems more difficult.

Cleartype and font smoothing are both on systemwide. Disabling any of them makes the fonts even worse.

Thanks in advance.

Attached screenshots

الحل المُختار

Actually, I fixed the issue. Setting gfx.direct2d.force-enabled to true was all it took.

Read this answer in context 👍 1

All Replies (1)

more options

الحل المُختار

Actually, I fixed the issue. Setting gfx.direct2d.force-enabled to true was all it took.