Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I keep Firefox from opening an extra page (default page) every time? I only want to open my Homepage.

  • 14 replies
  • 5 have this problem
  • 1324 views
  • آخر ردّ كتبه John99

more options

Two tabs always open. 1 with my homepage and one with the FF default page. This is so irritating that I seldom use the Firefox browser even though its faster that IE.

Chosen solution

I finally deleted all traces of Firefox on my computer, including all of the stuff that Uninstall did not delete. Then I reinstalled from scratch. That seems to work and I now get only one tab when I open the program.


Comment from a forum moderator (~J99)

Please note this is usually a solution of last resort. I suggest anyone wishing to follow such a solution ensures they back up the Firefox profile first. Please also see:

Read this answer in context 👍 0

All Replies (14)

more options

Hi, please see - How to set the home page, and make sure that 'Home Page' shows only your chosen home page address.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

As I said originally, my homepage is one of the 2 pages. The other is apparently the FF default page which I do not want to open. The home page icon only lists my home page. If there is a preference to open 2 pages originally I don't know where it is. By the way If I click a link and open it in another window I also get 2 pages - the link and the FF default.

Modified by jimgramling

more options

(Tools} > Options -> General

Near the bottom where it says Reset to Default - use that button, then re-do your homepage setting, but make sure that you don't have any other Tabs open when you use the "Use Current Page" button.

more options

Thanks but that did not change anything. I still get a second page opening. Maybe it's not the FF default page after all. The title on the tab says "new tab" and it contains several icons including Facebook, Twitter, You Tube, Best Buy and several others. Since I don't use any of these I don't know where they came from and why they show on the unwanted page.

more options

First of all check your shortcuts have not been changed to add some address to open

There are other possibilities, and whether or not something has changed the shortcut there could be other changes.

Thus is looking like it could be a toolbar, adware or malware the following information may help those trying to assist:

What are the values of the following preferences (default value)

N.B. edit homepage for privacy if necessary but I am expecting only part of the entry to be what you entered and to include the "pipe" symbol If it was three tabs it could for instance be

about:newtab|about:home|<your url>

The info is obtained from about:config as follows

  1. Type into the addressbar about:config
  2. Use Enter (or click the arrow icon)
  3. Accept any warning you may see
  4. Filter by typing in br, wait a while as it filters, then scroll to each of the listed prefs. (or individually type or paste each one in, in full )
  5. When highlighted the values may be copied from a right click option.

It is probably worth looking for potentially unwanted Firefox addons, and any unwanted programs installed in Windows and listed from the control panel.

I suspect your homepage and newtab settings are getting changed. You may also have also have a file user.js in the profile.

See also

more options

John Below are the contents of the preferences. The browser.newtab.url; is blank.

browser.newtab.url; browser.newtabpage.directory.source;https://tiles.services.mozilla.com/v3/links/fetch/%LOCALE%/%CHANNEL% browser.startup.homepage;http://www.google.com/

I uninstalled Firefox and reinstalled but that resulted in no change. Apparently the preferences were somehow saved because they are the same as before the uninstall.


Just to try and clarify, I'm pretty sure the problem is not related to malware, a tool bar, etc. since the first tab is the home page that I want (Google) second tab is "new tab" (that now is blank after I changed my preferences) which appears to be an integral part of Firefox. I do not want "new tab" to open every time I start Firefox. ALL I want is my homepage. If there is no way to prevent "new tab" from opening just tell me and I'll use Chrome or IE and delete Firefox.

more options

The above settings indicate only the one homepage: Google You should not be getting a second tab opening.


Test the Homepage Icon

What happens if you have a window open with one tab on it. This forum for instance. Then click on the hompage icon ?

If as apears you have one homepage tab that page should be replaced withthe homepage, but no aditional tab should open. If you do repetedly ckick the homepage icon it should remain as one tab.

If you have two homepage tabs the first click should open a second tab, in addition ato overwritng the originaltab, then repet clicks will increse the number of tabs seen.


Did you check your shortcuts ? Did you look at Wrong home page opens when I start Firefox - How to fix Whats the full text of the shortcut target ? (edit for privacy so replace say john-doe with <name>)


RESET browser.newtab.url That pref when exmined in gout config would be expected to be showing

Name

browser.newtab.url

Status

default

Value

about:newtab

Find it again in about:config, highlight and right click, select the reset option. That should reset it as above.

Before you do that, what currently happens if you click on the new tab plus (+) button on the toolbar top right ? Or if you usse keyboard shortcut Ctrl+T

more options

I onlu have one Home icon and when I have one tab open and click it I get Google which is what I want. If I click it multiple times I only get one tab with Google. I did check the link you sent about the Wrong home page. First I'm not getting the "wrong" home page I'm getting two.

The text in the short cut is ""C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

I reset the Browser.newtab.url. Still get 2 pages opening

more options

Did you check for problems with the preferences?

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the current Firefox profile folder:

more options

Chosen Solution

I finally deleted all traces of Firefox on my computer, including all of the stuff that Uninstall did not delete. Then I reinstalled from scratch. That seems to work and I now get only one tab when I open the program.


Comment from a forum moderator (~J99)

Please note this is usually a solution of last resort. I suggest anyone wishing to follow such a solution ensures they back up the Firefox profile first. Please also see:

Modified by John99

more options

Glad you fixed it, but I guess you lost your bookmarks and passwords etc. We could have explained how to preserve those.

more options

Since none of your other suggestions did any good I had no confidence that you could fix anything.

more options

jimgramling said

Since none of your other suggestions did any good I had no confidence that you could fix anything.

We try to suggest first of all, the options that do the least damage but may work given the symptoms reported.

Totally removing everything and reinstalling Firefox, or for that matter reformatting the hard drive and reinstalling the OS will fix most software issues but is rarely the advice anyone wants, and is best done after ensuring there are suitable backups.

Modified by John99