ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to fix google homepage searchbox skewed in ff38

  • 9 ردود
  • 1 has this problem
  • 216 views
  • آخر ردّ كتبه capt_benson

more options

For some reason, the "search box" on the google homepage is "skewed" when I upgrade to ff38 (actually this started happening for anything greater than about version 24). The page displays normally except the the search box is shifted to the left by about 3 inches. Also when I type in it the text is also not displayed correctly (not centered in the box). It's not "fatal", but very annoying. Any ideas on how to fix this would be appreciated. Thanks

Attached screenshots

Modified by capt_benson

الحل المُختار

You're welcome.

Maybe it is possible to modify the script to behave better or use CSS code in userContent.css instead.

Read this answer in context 👍 1

All Replies (9)

more options

If you have made changes to Advanced font size settings like increasing the minimum/default font size then try the Default font size setting "16" and the Minimum font size setting "none" in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))
more options

What is the address of that page? I'm having difficulty getting that set of bars and links for comparison.

more options

cor-el ...Thanks for the reply. I tried all 3 suggestions, but no joy.

jscher2000...here is the url for the page in my screenshot

https://www.google.com/?gws_rd=ssl&as_qdr=all

https://www.google.com/?gws_rd=ssl&as_qdr=all

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

more options

Thank you for the solution. It was the "grease monkey" add-on that was causing the problem. I liked the original "clean and all-white" classic google home page, not the black bar across the top so I had the grease monkey script on there to make that happen. So now I don't get rid of the black bar, but that's not as bad as the offset search box so I guess I'll live with it. Thanks again.

more options

الحل المُختار

You're welcome.

Maybe it is possible to modify the script to behave better or use CSS code in userContent.css instead.

more options

Thanks. I'll probably just get used to the dreaded black band. Oh well.

more options

Is the script hosted on OpenUserJS or GreasyFork? It may have been updated since the old days and have an active developer.

https://openuserjs.org/ https://greasyfork.org/

more options

I looked for the script in both those places, but didn't find it. I'm just going to accept the black bar and try to get used to the other changes. Thanks though.