Search Support

unable to open a private browser ie ctrl+shift+p not working.

  • 2 replies
  • 1 has this problem
  • 8 views
  • آخر ردّ كتبه the-edmeister

more options

please advice how to enable the private browser. I have temporarily borrowed my friends system for few days. It is not having the 4 lines icon which was on my system. and not able to open through short cut

All Replies (2)

more options

Hi, that is a very old version of Firefox which needs to be updated!

You should be able to open private browsing from the menu bar > File > New Private Window. To bring up the menu bar temporarily, press Alt. If you would like it to remain there all the time, right click in the tab bar (but not on a tab) and tick/check Menu Bar.

Firefox can also be updated from the menu bar > Help > About Firefox.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

That old version of doesn't have Private Browsing; it was introduced in a much later version of Firefox. If you are using a borrowed PC, you shouldn't update your friend's software without his permission.

Buy a USB Flash stick and install Firefox Portable on it. http://portableapps.com/apps/internet/firefox_portable You'll then have your own version of Firefox to use on any Windows PC / laptop, which won't affect any software that is already installed on that device. Whatever you "do" or save in Firefox Portable will be on that Flash stick.