ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps changing url in address bar, even when I type complete url. How do I force my search?

  • 13 ردًا
  • 3 have this problem
  • 9813 views
  • آخر ردّ كتبه CiaoBella1

more options

I do business with the same companies daily, weekly, or on a very regular basis. When I obtain a new business account or customer, I try to remember to delete the wrong results in address bar. I type over the complete url (.com) in address bar, but Firefox forces from memory (or history) and the only way I can get where I must go is from typing the address from within a search engine.

I about:configged auto fill,but that didn't work. I also tried autofill.typed, but that didn't work. I attempted to change Tools > location bar, but the choices are not good. I hardly ever search from bookmarks and my history is too often used to delete. (It seems counterproductive). How do I stop Firefox from forcing me to go places I do not want to go?

This is similar - in the sense of remembering crap I don't want it to remember - and making my searches far more difficult. I have had problems - especially in Amazon. I've written a couple of times. Nobody has ever gotten back to me on why FIREFOX has so many problems. If I don't get answers here, how do I get answers? I don't want to use IE and I don't want to have to avoid certain websites because the results suck. I'm in limbo until some solutions are found.

Thank you.

الحل المُختار

I'm not sure whether the problem is that Firefox itself is modifying the address you type in the address bar, or whether the site is immediately redirecting Firefox to a different page when it tries to go to the address you specified.

For example, 1&1 Webmail currently redirects to this site for login: https://webmailcluster.perfora.net/

Read this answer in context 👍 0

All Replies (13)

more options

Hi CiaoBella1, I understand that Firefox changes the url when you type in the url bar. This can be changed in the Settings.

  1. Open up the Firefox Menu button
  2. Click on Options/Preferences
  3. Click on Privacy and under Location Bar uncheck what you do not want to auto complete.
more options

Thank you, guigs2.

more options

CiaoBella1 said

I type over the complete url (.com) in address bar, but Firefox forces from memory (or history) and the only way I can get where I must go is from typing the address from within a search engine.

I about:configged auto fill,but that didn't work. I also tried autofill.typed, but that didn't work.

Hmm, that's strange. You set browser.urlbar.autoFill to false already? That should prevent Firefox from completing the URL in the address bar but you will still be able to select items from the list below the address bar if you want to.

Can you give an example of a change from what you typed to what you got?

One suggestion would be to bookmark the pages you want to access in the future. Then when you are typing part of the title or URL in the address bar, Firefox should suggest the bookmark in the drop down list with a blue star on the right side. That should make it easier to get to that site in the future.

more options

I frequently use http://portal.digitek.com/CommercePortal/ (I really just enter "dig" and it pulls up the portal.)

If I want to see the home page, I type digitek.com. 99% of the time, even if I type the full URL in the address bar, I still end up at the portal. I fight with pages all the time. Many more examples, but you wanted one.

It overrode the Portal page now - and Digitek,com was the second choice, but this is after resetting Config to False (and then back to True), and playing with Tools > Privacy > Location Bar. I couldn't have done it this easily yesterday - trust me!

Thank you, JScher2000.

Maybe it's time for a new laptop...

more options
more options

JScher2000,

Yeah, back to this.

I am having troubles (multiple) with webmail. It's webmail 1+1. Newish - I'm getting long delays in loading the login page and then opening email after I click login. I am using my notification email from 2008. It wants me to update, but it's the fastest access. I don't know why I have so many urls and I probably wouldn't complain if the one I keep getting actually worked. It doesn't.

I tried keyword enabled (false) and that DID NOT work. I can override the url by Tools > uncheck History, but that makes everything else really difficult. Surely there must be some other Firefox configuration that I can tweak. NO?

I only use bookmarks for one website - I don't find it convenient at all. Feel free to tell me if I am being too stubborn, but if I didn't think a tweak exists somewhere, it certainly OUGHT to.

Thank you.

more options

الحل المُختار

I'm not sure whether the problem is that Firefox itself is modifying the address you type in the address bar, or whether the site is immediately redirecting Firefox to a different page when it tries to go to the address you specified.

For example, 1&1 Webmail currently redirects to this site for login: https://webmailcluster.perfora.net/

more options

Where do We draw the line at redirects?

It's one of the defaults in my address bar. But I clicked on your link and my address changed to https://email.1and1.com/appsuite/#, which would not load. Y?

That's why I'm using a 2008 email.

Thank you.

more options

CiaoBella1 said

I clicked on your link and my address changed to https://email.1and1.com/appsuite/#, which would not load. Y?

I think that means the site detected that you were already logged in (cookie). I don't know why that page won't load for you. Have you tried the usual things, such as cache, cookies, extensions, etc.?

more options

I deliberately logout each time I leave. Well, I know it doesn't track. I don't know how many types of cookies there are, but no, the last thing I would think of doing is clearing cache, cookies, extensions. You know that old actress - "I just vant to be left alone." That's me.

I had been trying to solve memory cache and other cache issues along with the many troubleshooting tips I followed to try to handle Amazon. I asked about these months ago and never resolved - like about:config user-created settings.

How's your Amazon issue? Maybe my troubles transferred to you - or maybe they did a rolling release and it's just hitting your area now.

Thank you, JScher2000.

more options

JScher2000 - I have no patience, so I am cheating.

Feel free to yell. I spent two hours on phone and moving mail from spam to inbox via IE. For twenty-three days, I haven't been able to access webmail. I go to the different saved urls (this was in my complaint to you) in address bar and the website never opened.

I could access it ONLY through my invitation to join (we created an email account, click here). However, this was last year's pre-update version. Bad and difficult to use, but alright. One week ago, all my incoming went into SPAM. Today, I finally called.

As of July 1, I can only access my primary email account through my nemesis browser, IE. I will quit FF before I use IE as my default. When I mentioned 6/30 - the date as last accessed (of three urls )on my Password Mgr program, so it IS only a guess - or 7/1, she said nothing special happened on that day. Who knows...

The webmail is: https://webmail.1and1.com. I also accessed login page here: https://webmailcluster.perfora.net. It only loaded and opened here: https://email.1and1.com/ox6/ox.html.

I started off on my tablet - getting Error 404 messages in trying to view my damned rehab videos, so it's been an awful Firefoxy day.

Yes, I cleared cache on all browsers once today.

Thank you - !

more options

If you haven't already, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Can I take you home with me?

You are the BEST. Will expound another day.

Thank you, jScher2000.