X
Tap here to go to the mobile version of the site.

منتدى الدعم

Problems on Firefox for Windows 10

Posted

Computer details: Windows 10 Technical Previewer Build 10074 GPU drivers: latest AMD official 14.12 drivers (NOT WINDOWS BETA DRIVERS) Firefox version: 38.0.1 Build ID: 20150513174244

The problem is the one that can be seen in the screenshot attached. I pointed every place in the Bookmarks toolbar and above where the icons randomly disappear. This is also true for most icons/images in the page. It mostly happens when CTRL+TAB/ALT+TAB into Facebook, but it has also happened in some other websites.

This was happening in same Windows build with previous (I think 38.0.0) Firefox version. Windows was reinstalled and it kept happening. Tried disabling all add-ins and tried launching Firefox on secure mode, nothing has helped at all. Attached troubleshooting information in case this helps.

At this moment, Firefox is UNUSABLE due to constant crashes and visualization glitches, all part of the same issue.

Computer details: Windows 10 Technical Previewer Build 10074 GPU drivers: latest AMD official 14.12 drivers (NOT WINDOWS BETA DRIVERS) Firefox version: 38.0.1 Build ID: 20150513174244 The problem is the one that can be seen in the screenshot attached. I pointed every place in the Bookmarks toolbar and above where the icons randomly disappear. This is also true for most icons/images in the page. It mostly happens when CTRL+TAB/ALT+TAB into Facebook, but it has also happened in some other websites. This was happening in same Windows build with previous (I think 38.0.0) Firefox version. Windows was reinstalled and it kept happening. Tried disabling all add-ins and tried launching Firefox on secure mode, nothing has helped at all. Attached troubleshooting information in case this helps. At this moment, Firefox is UNUSABLE due to constant crashes and visualization glitches, all part of the same issue.
Attached screenshots

Chosen solution

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Read this answer in context 14

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 17.0 r0
  • 5.1.20513.0

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.2 (adblockpopups@jessehakanen.net)
  • Element Hiding Helper for Adblock Plus 1.3.2 (elemhidehelper@adblockplus.org)
  • Stylish 2.0.2 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon R9 200 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6811
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10074.0
  • driverDate: 4-28-2015
  • driverDate2:
  • driverVersion: 15.200.1023.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon R9 200 Series (Engineering Sample - WDDM v2.0) Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158888 answers

Chosen Solution

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

cor-el said

You can try to disable hardware acceleration in Firefox.
  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
You need to close and restart Firefox after toggling this setting.

At the very least, that diminished the problem substantially. Any idea why hardware acceleration might be working this bad? I have a new AMD R9 270 that is working flawlessly... Anyway, thank you very very much :D

''cor-el [[#answer-730258|said]]'' <blockquote> You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration </blockquote> At the very least, that diminished the problem substantially. Any idea why hardware acceleration might be working this bad? I have a new AMD R9 270 that is working flawlessly... Anyway, thank you very very much :D
sjobirek 0 solutions 3 answers

Helpful Reply

Immediately after upgrading to Windows 10, I started Firefox and it crashed to the point I had to kill windows.

Funny thou, before it crashed, it displayed screen "Windows 10 + Firefox = Perfection" or something similar. I tried again several times and each time Firefox stopped responding after few clicks, but I haven't experienced the display problems shown above. I even can't check which version of Firefox I run, before it crashes, but I believe it must be one of the most recent ones, as I installed Firefox a week ago, on Windows 8.1, where it worked perfectly well.

Now, I am going to uninstall Firefox and use Microsoft Internet Explorer instead, which is very sad, but necessary, I'm afraid.

Immediately after upgrading to Windows 10, I started Firefox and it crashed to the point I had to kill windows. Funny thou, before it crashed, it displayed screen "Windows 10 + Firefox = Perfection" or something similar. I tried again several times and each time Firefox stopped responding after few clicks, but I haven't experienced the display problems shown above. I even can't check which version of Firefox I run, before it crashes, but I believe it must be one of the most recent ones, as I installed Firefox a week ago, on Windows 8.1, where it worked perfectly well. Now, I am going to uninstall Firefox and use Microsoft Internet Explorer instead, which is very sad, but necessary, I'm afraid.