Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Private Browsing issues: New window is a "pop-up" & Right-clicking bookmarks shows grayed-out options

  • 29 replies
  • 54 have this problem
  • 4559 views
  • آخر ردّ كتبه RecoilRob

more options

When I'm in private browsing mode in Firefox 38.0.1 for Windows 8.1, I cannot do the following things.

1. When I click on a link to open a new window, that new window is like a pop-up window (no menus, no scroll-bars). But I have pop-up windows blocked, so it acts like but is not technically a pop-up window since it's not being blocked.

2. When I choose a bookmark and then right-click on it to choose another bookmark either in a new window or new tab (or any of the other options that appear), the text is grayed out so that I cannot choose it.

Are these "issues" normal for Firefox 38.0.1?

Chosen solution

My suggestions for settings were meant to be carried out in about:config. Type that into the address bar, press the return key, then change those settings. That will affect popup windows. Does it also affect the private windows?

Read this answer in context 👍 4

All Replies (9)

more options

Field of Stones said

The only "issue" (and it's a very minor one) is that the new window opens about 1/4 the size of a maximized window. So I have to maximize it manually.

Hi Field of Stones, Firefox should remember the size of a resizable window if you stretch it manually instead of maximizing it. However, websites occasionally do specify window sizes, so for those, Firefox would not use the stretched size. If Firefox seems to forget the stretched size and/or uses more screen than it should, that can indicate a different problem... which is for another day.

more options
more options

jscher2000 said

Field of Stones said
The only "issue" (and it's a very minor one) is that the new window opens about 1/4 the size of a maximized window. So I have to maximize it manually.

Hi Field of Stones, Firefox should remember the size of a resizable window if you stretch it manually instead of maximizing it. However, websites occasionally do specify window sizes, so for those, Firefox would not use the stretched size. If Firefox seems to forget the stretched size and/or uses more screen than it should, that can indicate a different problem... which is for another day.

Hi. I know this is not a website-specified window size issue because all new windows open at the same size now, whereas they did not before.

I've been stretching the window manually and clicking on links to open a new window repeatedly. The windows are opening at the same (original) size.

more options

FredMcD said

You may have a corrupt xulstore.json file. https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved

I did a refresh (although I don't know which files to copy from my old profile to my new profile for preferences and add-ons), but the new windows are opening at a different size (now about 3/4 a maximized window). I have been manually stretching and maximizing the new windows but Firefox doesn't remember.

I also had to do the about:config instructions dom.* (setting them to "true") because the original problem came back! But now they're good again.

more options

After a Refresh, it usually is best to reinstall extensions from the source site rather than copy them between profiles; you can see a list in the "More System Details" next to your original question. If the extension stored data in your old profile, the method for rescuing that data will depend on how it was stored (for example, text file, database, folder).

Firefox stores some settings in the prefs.js file -- such as toolbar customizations, pinned tabs, and the window-open features settings you modified again -- and others are in various other files. This article has more information on what you might want to transfer: Recovering important data from an old profile.

Alternately, you can revert to the old profile folder using the multi-step procedure in this post: https://support.mozilla.org/questions/1057756#answer-719277

more options

If there are preference settings you want to keep (such as the DOM settings for popups), then you can make a user.js file and copy those settings into it from prefs.js. Put that file into the profile in the same directory as prefs.js. I found it a good idea to make a backup copy of that and store it in a location outside of the profile as well.

more options

I have the same problem on a Mac, OS X 10.8.5, no scroll bar when in Private Browsing. Knew I should not have updated....

more options

Hi RecoilRob, Firefox 38 has a glitch with this combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank")

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Preferences > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.


For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.


Does that help?

more options

That did it for now jscher2000, thank you, seems to be working fine.


thanks,

Rob

  1. 1
  2. 2