X
Tap here to go to the mobile version of the site.

منتدى الدعم

Firefox always hangs. Spinning Beach Ball appears. Must Force Quit repeatedly. Have re-installed and refreshed with no change. How to fix?

Posted

Every time firefox is launched, the spinning beach ball appears, sometimes immediately, sometimes within a minute or two, every time. Must force quit. I have re-installed Firefox and also have refreshed with no change. Unless this is fixed, Firefox is unusable. I am running OSX 10.9.5 on a 17" MacBook Pro.

I cannot access any information through Firefox, because t always hangs.

Every time firefox is launched, the spinning beach ball appears, sometimes immediately, sometimes within a minute or two, every time. Must force quit. I have re-installed Firefox and also have refreshed with no change. Unless this is fixed, Firefox is unusable. I am running OSX 10.9.5 on a 17" MacBook Pro. I cannot access any information through Firefox, because t always hangs.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/600.4.10 (KHTML, like Gecko) Version/7.1.4 Safari/537.85.13

More Information

jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the option key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the option key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any less crashy?

Question owner

Thank you very much, but it didn't work. I did launch in Safe Mode OK, but the problem persists.

Thank you very much, but it didn't work. I did launch in Safe Mode OK, but the problem persists.
eglassman 0 solutions 2 answers

I'm having the exact problem on a Mac, Yosemite 10.10.5 Firefox 40.0.3

I'm having the exact problem on a Mac, Yosemite 10.10.5 Firefox 40.0.3

Modified by eglassman