ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I block the sponsered ads that show up on the blank page?

  • 9 ردود
  • 3 have this problem
  • 1290 views
  • آخر ردّ كتبه yfhgfjytdjdv

more options

I have Firefox set to not remember any history and to delete cookies on close. When I restart Firefox the blank page is filled with advertising.

الحل المُختار

Just click the gear icon in the top-right and change from 'enhanced' to 'classic' or 'blank.'

Read this answer in context 👍 2

All Replies (9)

more options

What do you mean by the blank page -- do you mean in the Preferences dialog you chose the startup option of a blank page? If that doesn't sound familiar, see: Startup, home page, tabs, and download settings

That page really should be blank! What if you change your startup option to use a home page, and for your home page specify

about:blank

(the built-in blank page)

Any difference? You can test by launching a new window (Command+n).

more options

If about:blank also is not really blank, my next suggestion would be to test in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

The page comes up when a new tab is selected. This article describes the offensive advertising: http://www.cnet.com/news/mozilla-to-sell-new-tab-page-ads-in-firefox/

more options

الحل المُختار

Just click the gear icon in the top-right and change from 'enhanced' to 'classic' or 'blank.'

more options

Delete the ads, set the gear icon to blank, give it a restart. So far so good. I am so overloaded with the advertising thrown at me from every angle. It just pissed me off and was about ready to dump Firefox (I like Firefox).

Thanks for the help!

more options

Do you mean the directory tiles on the about:newtab page?

If you want to remove the sponsored directory links on the about:newtab page then use these steps:

Set the browser.newtabpage.directory.source pref to an empty string on the about:config page.

  • browser.newtabpage.directory.source = <empty>

Delete the directoryLinks.json file in the parent location of the disk cache to remove the currently stored directory links.

  • delete directoryLinks.json

See the about:cache page for the location of the disk cache and go one level up.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

The "AppData" folder in Windows Vista and later Window 7+ versions and the "Application Data" folder in XP/Win2K are hidden folders.

more options

Thanks for the last set of instructions. it confirms the Mozilia is adapting nasty advertise practices, most users would just deal with it. Shame on Mozilla.

more options

Note that you can drag a bookmark or history item and drop them in a tile on the about:newtab page to pin them and have your own favorites sites showing.

See also this article about the New Tab page (about:newtab):

more options

Thanks for the fast and timely responses, very helpful.