X
Tap here to go to the mobile version of the site.

منتدى الدعم

I want to allow redirects but not auto-reloading

Posted

I'm running Yosemite on a Mac Air, with fully-updated everything.

I'd like to stop pages reloading without my permission. This is usually an issue for me on news sites.

In FF preferences, the option to allow or disallow auto-reloading is tied to the option to redirect. I can allow or disallow both, but not allow one and not the other.

The net effect is, my news sites aren't automatically refreshing (yay), but other sites get stuck when a page redirect comes up. I play Scrabble online; now I have to manually allow a redirect with every play. Same with following Twitter links.

Is there some way to kill off the auto-reloads while still allowing redirects? Maybe a whitelist for redirects, as a secondary option?

Thanks!

I'm running Yosemite on a Mac Air, with fully-updated everything. I'd like to stop pages reloading without my permission. This is usually an issue for me on news sites. In FF preferences, the option to allow or disallow auto-reloading is tied to the option to redirect. I can allow or disallow both, but not allow one and not the other. The net effect is, my news sites aren't automatically refreshing (yay), but other sites get stuck when a page redirect comes up. I play Scrabble online; now I have to manually allow a redirect with every play. Same with following Twitter links. Is there some way to kill off the auto-reloads while still allowing redirects? Maybe a whitelist for redirects, as a secondary option? Thanks!

Chosen solution

I do not know if the browser can tell the difference because it depends on the DNS server to give redirect requests back to the browser. Actually it does, 301 or 302 vs new http get request.... anyway:

I found this add on: Refresh Blocker and No Redirect which both let you control what sites to allow if there are only a few sites.

This would only be a temporary work around however.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Provides information about the default web browser
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0

Application

  • Firefox 36.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0.1/Darwin/en-US/

Extensions

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Classic Retweet 1.12 (classicretweet@jonpierce.com)
  • Evernote Web Clipper 5.9.1 ({E0B8C461-F8FB-49b4-8373-FE32E9252800})
  • Flashblock 1.5.18 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Greasemonkey 2.3 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • NoScript 2.6.9.17 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Firefox Certificate Store Hotfix 20150225.01 (firefox-hotfix@mozilla.org) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x a26
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 5000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Chosen Solution

I do not know if the browser can tell the difference because it depends on the DNS server to give redirect requests back to the browser. Actually it does, 301 or 302 vs new http get request.... anyway:

I found this add on: Refresh Blocker and No Redirect which both let you control what sites to allow if there are only a few sites.

This would only be a temporary work around however.

I do not know if the browser can tell the difference because it depends on the DNS server to give redirect requests back to the browser. Actually it does, 301 or 302 vs new http get request.... anyway: I found this add on: [https://addons.mozilla.org/en-us/firefox/addon/refreshblocker/ Refresh Blocker] and [https://addons.mozilla.org/en-US/firefox/addon/noredirect/?src=search No Redirect] which both let you control what sites to allow if there are only a few sites. This would only be a temporary work around however.

Question owner

It's a workaround that should do the job! Thanks very much.

It's a workaround that should do the job! Thanks very much.

Question owner

Ohhh, this is aggravating!

I mucked around with a couple options. Ultimately I decided to change the FF preferences and put up with manual redirects - the automatic reloading was the bigger bother.

So no sites are reloading - except the one that started me on this goose chase in the first place! The site just reloaded right in front of my face!

All the other sites I visit regularly have a "Firefox prevented this site from reloading" banner at the top. The site that prompted me to block reloading doesn't have that banner.

How is that site overriding my preferences, and how can I stop it?

Ohhh, this is aggravating! I mucked around with a couple options. Ultimately I decided to change the FF preferences and put up with manual redirects - the automatic reloading was the bigger bother. So no sites are reloading - ''except the one that started me on this goose chase in the first place!'' The site just reloaded right in front of my face! All the other sites I visit regularly have a "Firefox prevented this site from reloading" banner at the top. The site that prompted me to block reloading doesn't have that banner. How is that site overriding my preferences, and how can I stop it?
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157890 answers

What website is given you this problem?

It is likely that the website uses JavaScript to refresh the page and in this case the setting in Options > Advanced won't have effect.

What website is given you this problem? It is likely that the website uses JavaScript to refresh the page and in this case the setting in Options > Advanced won't have effect.

Question owner

I'm embarrassed to admit this, but: http://dailymail.co.uk/.

If it's using JavaScript, is there some way to blacklist that site?

I'm embarrassed to admit this, but: http://dailymail.co.uk/. If it's using JavaScript, is there some way to blacklist that site?
guigs 1072 solutions 11697 answers

Yesscript maybe?

[https://addons.mozilla.org/firefox/addon/yesscript/ Yesscript] maybe?