X
Tap here to go to the mobile version of the site.

منتدى الدعم

Search box doesn't work like it should

Posted

When I enter search terms into the Search Box, FF comes up with suggestions that don't work. Either they're wrong, or off-topic, or otherwise useless, and they're hard to delete or very difficult to change. FF wants to search only for what it wants to search for. How can I turn off the Search Suggestions? (The tick-box on setup has no effect). I just want to search on my terms, not Firefox's terms. Chrome's Search Box is excellent, but I don't like Chrome, so I've got to figure out how to get FF to search properly.

When I enter search terms into the Search Box, FF comes up with suggestions that don't work. Either they're wrong, or off-topic, or otherwise useless, and they're hard to delete or very difficult to change. FF wants to search only for what it wants to search for. How can I turn off the Search Suggestions? (The tick-box on setup has no effect). I just want to search on my terms, not Firefox's terms. Chrome's Search Box is excellent, but I don't like Chrome, so I've got to figure out how to get FF to search properly.

Modified by JJJoseph

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • McAfee MSS+ NPAPI Plugin
  • NPWLPG
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

Gnospen 233 solutions 1920 answers

What search engine are you using? Most search engines have a "adult"-filter. You set them through their pages. and should be turned of tthat way. You could thou have been hijacked by some ad-ware

What search engine are you using? Most search engines have a "adult"-filter. You set them through their pages. and should be turned of tthat way. You could thou have been hijacked by some ad-ware
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware

Question owner

Thatnks, but these suggestions are sort of "off topic". The Search Box appears to be badly designed compared to the Chrome equivalent. I'd like to turn OFF the Search Box suggestions so I don't have to struggle with them. Let's say I type in two words in the Search Box. Firefox may add a suggested third word so there's now three words.

Example:

I type "expo world" into the Search Box. FF suggests "expo world tour". I DON'T WANT "expo world tour", but I can't remove the word "tour" from the Search Box. I can't back-space it out or delete it; if I do succeed in deleting "tour", FF puts it back.

It's very annoying!

Thatnks, but these suggestions are sort of "off topic". The Search Box appears to be badly designed compared to the Chrome equivalent. I'd like to turn OFF the Search Box suggestions so I don't have to struggle with them. Let's say I type in two words in the Search Box. Firefox may add a suggested third word so there's now three words. Example: I type "expo world" into the Search Box. FF suggests "expo world tour". I DON'T WANT "expo world tour", but I can't remove the word "tour" from the Search Box. I can't back-space it out or delete it; if I do succeed in deleting "tour", FF puts it back. It's very annoying!
Gnospen 233 solutions 1920 answers

open about:config Make browser.search.suggest.enabled false

open about:config Make ''browser.search.suggest.enabled'' false

Question owner

"open about:config"

How do I do this?

"open about:config" How do I do this?
Gnospen 233 solutions 1920 answers

just write it in as an url about:config you get a warning, be careful continue search for "browser.search.suggest.enabled" (or part of it) doubleclick to change value. It takes effect immediately. Close About... tab try

just write it in as an url about:config you get a warning, be careful continue search for "browser.search.suggest.enabled" (or part of it) doubleclick to change value. It takes effect immediately. Close About... tab try

Question owner

?? Thunderbird doesn't like "about:config". It says "No receipients were specified". I could be making some kind of mistake since I don't really understand what you're saying.

?? Thunderbird doesn't like "about:config". It says "No receipients were specified". I could be making some kind of mistake since I don't really understand what you're saying.
Gnospen 233 solutions 1920 answers

Ain't we talking about FireFox ???????

And the solution is so simple and we couldn't find it.

Just right-click in the search bar and undo Show suggestions

Ain't we talking about FireFox ??????? And the solution is so simple and we couldn't find it. Just right-click in the search bar and undo '''Show suggestions'''

Modified by Gnospen