X
Tap here to go to the mobile version of the site.

منتدى الدعم

Disabling javascript alerts?

Posted

I am using an extension called Black YouTube Theme (https://addons.mozilla.org/en-US/firefox/addon/black-youtube-theme/). Currently Whenever I start Firefox using restore session from last time. For any YouTube links I have open it pops open a little JavaScript Application box, one per link, which returns "Error: document.domain is null". That is the only problem I have, so I was wondering does anyone know how to disable JavaScript error messages using about:config?

I am using an extension called Black YouTube Theme (https://addons.mozilla.org/en-US/firefox/addon/black-youtube-theme/). Currently Whenever I start Firefox using restore session from last time. For any YouTube links I have open it pops open a little JavaScript Application box, one per link, which returns "Error: document.domain is null". That is the only problem I have, so I was wondering does anyone know how to disable JavaScript error messages using about:config?

Chosen solution

capability.policy prefs aren't supported in current Firefox releases, so you can undo these steps.

If it only happens when you reopen pages automatically on the next start then this is likely caused by Firefox loading pages from the cache.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.6.156
  • 5.1.31211.0
  • Unity Player 4.3.7f1

Application

  • Firefox 35.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-US/

Extensions

  • about:addons-memory 10 (about-addons-memory@tn123.org)
  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Black Youtube Theme 5.5 ({2c93446d-612b-416d-9af0-b7355797b611})
  • Classic Theme Restorer 1.2.9.2 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Easy Youtube Video Downloader Express 7.37 ({b9acf540-acba-11e1-8ccb-001fd0e08bd4})
  • Flagfox 5.0.11 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Ghostery 5.4.1 (firefox@ghostery.com)
  • HTTPS-Everywhere 4.0.3 (https-everywhere@eff.org)
  • Lightbeam 1.2.0 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • OmniSidebar 1.5 (osb@quicksaver)
  • Private Tab 0.1.7.3 (privateTab@infocatcher)
  • Quick Translator 1.0 ({5C655500-E712-41e7-9349-CE462F844B19})
  • SimilarWeb 3.0.3.6 (FirefoxAddon@similarWeb.com)
  • YouTube Enhancer Plus 3.3.4 (firefoxaddon@youtubeenhancer.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2: NVIDIA GeForce GTX 870M
  • adapterDeviceID: 0x0416
  • adapterDeviceID2: 0x1199
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 3072
  • adapterSubsysID: 157d1043
  • adapterSubsysID2: 157d1043
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 12-20-2013
  • driverDate2: 1-9-2015
  • driverVersion: 10.18.10.3379
  • driverVersion2: 9.18.13.4725
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Diego Victor 658 solutions 4175 answers

ردّ مُفيد

Try this thread on mozillazine:

Try this thread on mozillazine: *[http://forums.mozillazine.org/viewtopic.php?t=15570]
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

Maybe disable the disk cache or clearing the cache on exit (Clear history when Firefox closes) will prevent this alert.

See also:

Maybe disable the disk cache or clearing the cache on exit (Clear history when Firefox closes) will prevent this alert. See also: *https://developer.mozilla.org/en-US/docs/Web/API/document.domain

صاحب السؤال

So from my understanding I just put:

"capability.policy.default.Window.alert", "noAccess" "capability.policy.default.Window.confirm", "noAccess" "capability.policy.default.Window.prompt", "noAccess"

As new variables in about:config?

So from my understanding I just put: "capability.policy.default.Window.alert", "noAccess" "capability.policy.default.Window.confirm", "noAccess" "capability.policy.default.Window.prompt", "noAccess" As new variables in about:config?

صاحب السؤال

forgottengods said

So from my understanding I just put: "capability.policy.default.Window.alert", "noAccess" "capability.policy.default.Window.confirm", "noAccess" "capability.policy.default.Window.prompt", "noAccess" As new variables in about:config?

These didn't work. I still receive 1 JavaScript Application "Error: document.domain is null" for every YouTube page open on restart.

''forgottengods [[#answer-685159|said]]'' <blockquote> So from my understanding I just put: "capability.policy.default.Window.alert", "noAccess" "capability.policy.default.Window.confirm", "noAccess" "capability.policy.default.Window.prompt", "noAccess" As new variables in about:config? </blockquote> These didn't work. I still receive 1 JavaScript Application "Error: document.domain is null" for every YouTube page open on restart.
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

Chosen Solution

capability.policy prefs aren't supported in current Firefox releases, so you can undo these steps.

If it only happens when you reopen pages automatically on the next start then this is likely caused by Firefox loading pages from the cache.

capability.policy prefs aren't supported in current Firefox releases, so you can undo these steps. If it only happens when you reopen pages automatically on the next start then this is likely caused by Firefox loading pages from the cache.

صاحب السؤال

I have disk cache set to 0 and the Boolean variable set to false. So I do not believe it is a cache issue.

I have disk cache set to 0 and the Boolean variable set to false. So I do not believe it is a cache issue.
finitarry 251 solutions 3421 answers

When was capability.policy removed? What next is going to be gutted out? I am really happy I use SeaMonkey.

When was capability.policy removed? What next is going to be gutted out? I am really happy I use SeaMonkey.

صاحب السؤال

It most likely has been replaced with a different name. I do not believe that they would remove something like that. Options/customization, is the whole reason I use Firefox. Without I might as well use Chrome.

It most likely has been replaced with a different name. I do not believe that they would remove something like that. Options/customization, is the whole reason I use Firefox. Without I might as well use Chrome.