X
Tap here to go to the mobile version of the site.

منتدى الدعم

How can I tell when I'm in a private browsing session - Firefox 35.0.1

Posted

When I open a private browsing window in Firefox v 35.0.1, there are no indicators that I'm actually in a private browsing window. In my previous version of Firefox, when using the "New Private Window" command, a new window would pop open that stated in the body: "You are currently browsing in private mode", or something to that effect. It would also display a purple mask in the upper right hand portion of the window near the maximize/minimize/close icons.

Now when I try to open a private window in FF 35, it opens a window that looks identical to the standard FireFox window, with nothing to indicate that i am browsing in private mode. What is happening?

I have attached a screenshot of the top portion of my browsing window while supposedly in a Private Window.

When I open a private browsing window in Firefox v 35.0.1, there are no indicators that I'm actually in a private browsing window. In my previous version of Firefox, when using the "New Private Window" command, a new window would pop open that stated in the body: "You are currently browsing in private mode", or something to that effect. It would also display a purple mask in the upper right hand portion of the window near the maximize/minimize/close icons. Now when I try to open a private window in FF 35, it opens a window that looks identical to the standard FireFox window, with nothing to indicate that i am browsing in private mode. What is happening? I have attached a screenshot of the top portion of my browsing window while supposedly in a Private Window.

Chosen solution

If you launch Firefox in the Private Browsing mode, using Always use private browsing mode which can be set in Options > Privacy --> Firefox will: Use custom settings for history -- you would be using Permanent Private Browsing mode.

The the "mask"' or a message of Private Browsing at the top of the Firefox window isn't displayed, and menu items and keyboard commands will only open another private window. You can't exit "private mode" without closing Firefox and un-ticking that "Always use ..." preference, before you open Firefox again.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Shockwave Flash 16.0 r0

Application

  • Firefox 35.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Diccionario de Español/México 1.1.3 (es-MX@dictionaries.addons.mozilla.org)
  • Norton Toolbar 2014.7.10.16 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon R9 200 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6810
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 30301462
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 9-11-2013
  • driverDate2:
  • driverVersion: 13.200.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon R9 200 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
user1089369 5 solutions 48 answers

The mask still appears for me and so does the little statement. So it isnt the version itself that is the issue. Are you sure your going to private browsing? (ctrl Shift p)

The mask still appears for me and so does the little statement. So it isnt the version itself that is the issue. Are you sure your going to private browsing? (ctrl Shift p)

Modified by user1089369

صاحب السؤال

luiz187, I have tried both the keyboard shortcut (Ctrl+Shift+P), and the drop down menu command. Both open a new browsing window, but the window that they open just looks like a normal Firefox window.

I have another computer running Windows XP with the same version of Firefox, that has no issues with opening a private window.

My current setup having issues runs windows 7 (64 bit). I cannot figure out what is wrong.

A curious note is that: the drop down menu, under File, shows Ctrl+N as the command for a new private window. But Ctrl+N is the standard command to open a new window, not a private window. I am accustomed to using Ctrl+Shift+P, as you have mentioned, to open a private window.

luiz187, I have tried both the keyboard shortcut (Ctrl+Shift+P), and the drop down menu command. Both open a new browsing window, but the window that they open just looks like a normal Firefox window. I have another computer running Windows XP with the same version of Firefox, that has no issues with opening a private window. My current setup having issues runs windows 7 (64 bit). I cannot figure out what is wrong. A curious note is that: the drop down menu, under '''File''', shows Ctrl+N as the command for a new private window. But Ctrl+N is the standard command to open a new window, not a private window. I am accustomed to using Ctrl+Shift+P, as you have mentioned, to open a private window.

Modified by H3arkenNot

the-edmeister
  • Top 25 Contributor
  • Moderator
5433 solutions 40564 answers

Chosen Solution

If you launch Firefox in the Private Browsing mode, using Always use private browsing mode which can be set in Options > Privacy --> Firefox will: Use custom settings for history -- you would be using Permanent Private Browsing mode.

The the "mask"' or a message of Private Browsing at the top of the Firefox window isn't displayed, and menu items and keyboard commands will only open another private window. You can't exit "private mode" without closing Firefox and un-ticking that "Always use ..." preference, before you open Firefox again.

If you launch Firefox in the Private Browsing mode, using '''Always use private browsing mode''' which can be set in Options > Privacy --> Firefox will: '''''Use custom settings for history''''' -- you would be using Permanent Private Browsing mode. The the '''"mask"''' '''or a message of Private Browsing'' at the top of the Firefox window isn't displayed, and menu items and keyboard commands will only open another private window. You can't exit "private mode" without closing Firefox and un-ticking that "Always use ..." preference, before you open Firefox again.
cor-el
  • Top 10 Contributor
  • Moderator
17866 solutions 161668 answers

ردّ مُفيد

You can use an extension to get Private Browsing mode support per tab.

  • Private Browsing mode tabs get a dashed underline
  • You can toggle Private Browsing mode on/off via the right-click context menu of a tab
You can use an extension to get Private Browsing mode support per tab. *Private Tab: https://addons.mozilla.org/firefox/addon/private-tab/ *Private Browsing mode tabs get a dashed underline *You can toggle Private Browsing mode on/off via the right-click context menu of a tab
aviav 0 solutions 3 answers

I just experienced something that looked just as you described it. Trying the console command 'firefox -private-window https://support.mozilla.org' opened a new tab (which looked non-private), and clicking the button which normally opens a new Private Browsing window opened a window that looked like a normal window, without the mask.

Then I restarted Firefox, and now it seems to work just fine again, both using the console command and the button.

I use 35.0.1 on Linux.

(Edit: Unfortunately, I could not reproduce this.)

I just experienced something that looked just as you described it. Trying the console command 'firefox -private-window https://support.mozilla.org' opened a new tab (which looked non-private), and clicking the button which normally opens a new Private Browsing window opened a window that looked like a normal window, without the mask. Then I restarted Firefox, and now it seems to work just fine again, both using the console command and the button. I use 35.0.1 on Linux. (Edit: Unfortunately, I could not reproduce this.)

Modified by aviav

the-edmeister
  • Top 25 Contributor
  • Moderator
5433 solutions 40564 answers

aviav said

... Trying the console command 'firefox -private-window https://support.mozilla.org' opened a new tab (which looked non-private), and clicking the button which normally opens a new Private Browsing window opened a window that looked like a normal window, without the mask. ...

Using that -private-window command works the same as using "permanent browsing" via Options / Preferences > Privacy.

''aviav [[#answer-686688|said]]'' <blockquote> ... Trying the console command 'firefox -private-window https://support.mozilla.org' opened a new tab (which looked non-private), and clicking the button which normally opens a new Private Browsing window opened a window that looked like a normal window, without the mask. ... </blockquote> Using that '''-private-window''' command works the same as using "permanent browsing" via Options / Preferences > Privacy.

صاحب السؤال

the-edmeister said

If you launch Firefox in the Private Browsing mode, using Always use private browsing mode which can be set in Options > Privacy --> Firefox will: Use custom settings for history -- you would be using Permanent Private Browsing mode. The the "mask"' or a message of Private Browsing at the top of the Firefox window isn't displayed, and menu items and keyboard commands will only open another private window. You can't exit "private mode" without closing Firefox and un-ticking that "Always use ..." preference, before you open Firefox again.

Thanks for your help everyone. Edmeister: I went into the privacy options under History, I had "never remember history" set as my choice. Apparently that assumes a default setting that behaves in the same way as what you described. If I change the drop down option to "use custom settings for history", it then gives me the option to check or uncheck the "always use private browsing mode" (default was checked). When I unchecked that option, Firefox prompted for a restart and then allowed me to open a private window as normal. Thanks again!

''the-edmeister [[#answer-685931|said]]'' <blockquote> If you launch Firefox in the Private Browsing mode, using '''Always use private browsing mode''' which can be set in Options > Privacy --> Firefox will: '''''Use custom settings for history''''' -- you would be using Permanent Private Browsing mode. The the '''"mask"''' '''or a message of Private Browsing'' at the top of the Firefox window isn't displayed, and menu items and keyboard commands will only open another private window. You can't exit "private mode" without closing Firefox and un-ticking that "Always use ..." preference, before you open Firefox again. </blockquote> Thanks for your help everyone. Edmeister: I went into the privacy options under History, I had "never remember history" set as my choice. Apparently that assumes a default setting that behaves in the same way as what you described. If I change the drop down option to "use custom settings for history", it then gives me the option to check or uncheck the "always use private browsing mode" (default was checked). When I unchecked that option, Firefox prompted for a restart and then allowed me to open a private window as normal. Thanks again!