ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't load pages unless mouse is moving or keyboard is pressed

  • 44 ردًا
  • 16 have this problem
  • 10365 views
  • آخر ردّ كتبه Keith172

more options

Hello,

I've seen this problem listed several times prior to this post, but none of the solutions have helped me.

I've been using Firefox for ages and the last 3 updates or so have been exhibiting this issue. When I attempt to load a website, Firefox will begin to take me to the page and then hang. The circle in the tab will stop moving and it will sit there until I move the mouse or press a button on the keyboard. As long as the mouse is continuously moving or keyboard buttons are pressed, the page will load fine. The same thing happens with YouTube. The video will start and then freeze unless the mouse/keyboard is moved. Firefox also exhibits this behavior when I try to download a file from a website. The download will start and then hang until I move the mouse or press a button, then it will continue for a few seconds and hang again until I repeat the mouse movement or keyboard button press.

So far, I've tried updating Firefox, Java and Flash; starting Firefox in Safe Mode; uninstalling and reinstalling Firefox: doing a complete uninstall and reinstall of Firefox with profile removal and creation. I've run the following ad and malware detection tools with no infections found: Malwarebytes' Anti-Malware, AdwCleaner, SuperAntispyware, Microsoft Safety Scanner, Windows Defender, Spybot Search & Destroy, Kasperky Free Security Scan and Anti-rootkit utility TDSSKiller.

The only thing that I've tried that "seemed" to work was starting Windows in Safe Mode with networking and running Firefox there. I was able to watch YouTube videos without freezing and websites appeared to load properly. Obviously, I can't run in Safe Mode all the time.

I've attached a screenshot of what it looks like when Firefox hangs on Google News. Notice that the images partly load, but a good number of them are either waiting or not loaded.

I hope someone can help me, since I really like Firefox and I'd hate to switch to Chrome or (shudder) IE.

Thanks in advance for your help!

الحل المُختار

philipp - Ah ha! When I disabled all non-Microsoft services in msconfig and restarted the PC, Firefox behaved like it used to with no freezing! So now it's just a matter of figuring out which service(s) are causing the issue, right?

Read this answer in context 👍 0

All Replies (20)

more options

the issue is commonly related to external factors (thus it will work in windows safe mode) - if all the security tools didn't find something malicious (maybe it's worth a try to run some of them in safe mode as well?), you could also take a look at your auto-start programs and try reducing them as much as possible. here for example it has been discovered that a screenshot capturing tool called shrinkpic was causing the issue...

more options

philipp, I'm with you there. I did try running all of the anti-malware and anti-spyware programs in Windows 7 Safe Mode last time and they only found some cookies, which I let them delete. The only one that didn't want to run in Safe Mode was Kaspersky, for some reason.

I did have a screenshot program I used called Gadwin PrintScreen v 4.7. Just in case that was the issue, I disabled it from msconfig, but it restarted itself. So I uninstalled it. No luck. Then I went through msconfig and tried disabling small batches (3-4) of programs from startup at a time. No luck there either. I then tried starting Windows in Safe Mode with networking again to test and FireFox ran fine there.

Some additional info and hopefully the pics will upload this time:

  1. The first image is of the FireFox splash screen when I open it. The animated gif of the radar screen with the slash through it stops animating unless I move the mouse.
  2. The second image is of some odd graphical "artifacts" (within the circles) I've seen lately. Not sure it's related, but I figured it couldn't hurt to mention, just in case.
more options

Keith172 said

  1. The second image is of some odd graphical "artifacts" (within the circles)

The padlock is Firefox letting you know the web link is secure. The round arrow is a button. Press it to reload the current page.


Security issue: Update your Flash Player v16.0.0.296
https://www.adobe.com/products/flashplayer/distribution3.html

more options

Please open your Task Manager. Select Processes.

Take a screen shot of all the pages. Miss Nothing !


Taking a Screen shot; Windows > Start > search box > Snip. Select Snipping Tool.

Save the picture(s) to your desktop. Now look at the Reply box below. Press the button under it that says Browse. Now select the screen shot(s) from the desktop and load them one at a time.

more options

FredMcD said

Keith172 said
  1. The second image is of some odd graphical "artifacts" (within the circles)

The padlock is Firefox letting you know the web link is secure. The round arrow is a button. Press it to reload the current page.


Security issue: Update your Flash Player v16.0.0.296
https://www.adobe.com/products/flashplayer/distribution3.html

FredMcD, the "artifacts" I'm talking about are those odd blue colored boxes around the padlock and reload buttons. The blue boxes go away if I move my mouse over them.

I updated my Flash Players (IE and FF). I'll upload the Processes in my next reply.

more options

FredMcD, attached please find the Task Manager screenshots you requested. The first one is just me, the second and third are with All Users selected.

Modified by Keith172

more options

Keith172 said

FredMcD said
Keith172 said
  1. The second image is of some odd graphical "artifacts" (within the circles)

The padlock is Firefox letting you know the web link is secure. The round arrow is a button. Press it to reload the current page.


Security issue: Update your Flash Player v16.0.0.296
https://www.adobe.com/products/flashplayer/distribution3.html

FredMcD, the "artifacts" I'm talking about are those odd blue colored boxes around the padlock and reload buttons. The blue boxes go away if I move my mouse over them.

I updated my Flash Players (IE and FF). I'll upload the Processes in my next reply.

Also, here's a few more screenshots of the "artifacts". Strange lines and colors that tend to disappear when I move the mouse over them.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

Open the options of CCleaner and have it leave Firefox alone. Do the same with any other protection programs.

more options

cor-el said

You can try to disable hardware acceleration in Firefox.
  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
You need to close and restart Firefox after toggling this setting.

cor-el, I disabled hardware acceleration in my full re-install of FireFox and that seems to have eliminated those graphical anomalies on the address bar. Thank you.

Modified by Keith172

more options

FredMcD said

Open the options of CCleaner and have it leave Firefox alone. Do the same with any other protection programs.

FredMcD, I turned off FireFox scanning in CCleaner and Spybot S&D. Should I add an exclusion to MS Security Essentials or leave that alone?

more options

Not a bad idea.

more options

FredMcD said

Not a bad idea.

Done.

more options

Does anyone have any thoughts on the process lists I posted? I'm still having the freezing issue.

more options

how is it behaving when you create a new windows user account and start firefox there?

more options

philipp, I tried creating a new Windows user account and Firefox exhibits the same freezing behavior there.

more options

another thing to try would be to disable non-microsoft services in msconfig...

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift (Mac Options) > key, and then starting Firefox. Is the problem still there?

more options

الحل المُختار

philipp - Ah ha! When I disabled all non-Microsoft services in msconfig and restarted the PC, Firefox behaved like it used to with no freezing! So now it's just a matter of figuring out which service(s) are causing the issue, right?

more options

FredMcD - When I started FireFox in safe mode before, there was no change in behavior. It still kept freezing.

  1. 1
  2. 2
  3. 3