ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I make google search results appear in english when I am in a foreign country?

  • 10 ردود
  • 1 has this problem
  • 23168 views
  • آخر ردّ كتبه kaialoha

more options

Every google search redirects to spanish (I am visiting Mexico) and I can not find a way to disable that in the tools/options tab of the Firefox browser.

الحل المُختار

Hello Sudokuman, install a specific google-search-plugins from Mycroft Project : http://mycroftproject.com/google-search-plugins.html

thank you

Read this answer in context 👍 0

All Replies (10)

more options

Sudokuman said

Every google search redirects to spanish (I am visiting Mexico) and I can not find a way to disable that in the tools/options tab of the Firefox browser.

This is an attribute of Google, not Firefox. Try this (tested on the SSL-enabled Google page): https://encrypted.google.com/ "Settings" (bottom-right corner) "Search settings" (on the pop-up) "Languages" (on the left side) Select which language you want Google products to use ... and Confirm that the "Currently showing search results in:" setting matches your preference.

(These settings should be associated with your logged-in Google account, if you're using one.)

more options

Thanks! I have done this and still have google overriding the search and switching to Spanish. I believe I can start a new google account and work around this by registering as being in the US even though I am in Mexico. Trying that next. For the record in the bottom right of the google page it says "use Google.com.mx and I can't seem to change that to .us.

more options

How about changing to DuckDuckGo as search-engine? It uses Google, and others and have a easy language-switch.

more options

الحل المُختار

Hello Sudokuman, install a specific google-search-plugins from Mycroft Project : http://mycroftproject.com/google-search-plugins.html

thank you

more options

Sudokuman said

Every google search redirects to spanish (I am visiting Mexico) and I can not find a way to disable that in the tools/options tab of the Firefox browser.
more options

This has been corrected, perhaps restarting after trying these solutions made the difference. Thanks!

more options

Note that such issues can be caused by corrupted cookies or cookies that are blocked.

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
more options

If I recall correctly, going to http://www.google.com/ncr will set a cookie indicating that you do not want to be redirected from the .com site to a country-specific site.

more options

jscher2000 said

If I recall correctly, going to http://www.google.com/ncr will set a cookie indicating that you do not want to be redirected from the .com site to a country-specific site.

just tried this. fingers crossed. aloha kai

more options

user799679 said

How about changing to DuckDuckGo as search-engine? It uses Google, and others and have a easy language-switch.

I use DNGG but still same problem.