Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Issues with numerous websites (Twitch, Reddit, Yahoo etc)

  • 8 replies
  • 1 has this problem
  • 1211 views
  • آخر ردّ كتبه AliceWyman

more options

Hi,

This morning I have experienced problems using several websites through Firefox. All these websites seem to work fine through IE and Chrome. I have attempted some basic maintenances (rebooting, virus scan, clearing caches) but the problem persists:

Issues include:

Twitch TV: Busy symbol. No videos shown Reddit: Cannot post messages. After resetting cache, I can no longer log in Yahoo mail: Can see message list. However when I click on a message to open it, nothing happens, so I cannot read mail Azubu TV: Badly formatted web page

I wonder if this is connected to any of the installations I have performed recently? These include:

About 5 days ago: Installeed Elite Dangerous: Two days ago: Nvidia driver update Last night: Update to Marvel Heroes. First time I've used it in 6 months. It installed 76 patches. I've posted a query on their support forums here: https://forums.marvelheroes.com/discussion/161083/marvel-heroes-updated-firefox-down

I haven't knowingly installed anything else during the past week, although it's possible applications such as Steam may have performed background updates. i don't know what has caused this issue, but I currently consider my Firefox installation to be broken, and would like to fix it. Any help you could offer would be appreciated.

Chosen solution

Hi there,

Have you tried opening Firefox in Safe Mode?

In case you're not aware, Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please let me know how you go, or if you need any further assistance.

Tim

Read this answer in context 👍 1

All Replies (8)

more options

Chosen Solution

Hi there,

Have you tried opening Firefox in Safe Mode?

In case you're not aware, Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please let me know how you go, or if you need any further assistance.

Tim

more options

Ok - safe mode does seem to fix the issue. I'll try following your link to track down the cause.

more options

Confirmed - the problem seems to be caused by AdBlock+. Or at least it goes away when the add-on is disabled.

Pity - that add-on is one of Firefox's best features. I hope they fix it soon!

Modified by Cathartic

more options

Great to hear you were able to identify the cause.

Adblock+ is software made by a 3rd party and not by Mozilla. The good news is that there are a few other addons that do the same job.

Check out the Firefox addons site and try out another one perhaps?

Tim

more options

AdBlock Plus has its own forums: https://adblockplus.org/forum/index.php ... so, if you want to solve your issues with AdBlock Plus you can ask for help there.

The replies in this earlier question may also help: https://support.mozilla.org/en-US/questions/1037720

more options

A small update - I've now moved to a fork of Adblock called "Adblock Edge". It doesn't seem to suffer from the same issue.

more options

Go to the web page. After it is loaded, click the AdBlock down arrow to open the settings. Turn on Disable On Site Name

more options

Cathartic said

A small update - I've now moved to a fork of Adblock called "Adblock Edge". It doesn't seem to suffer from the same issue.

Thanks for the followup. I'm glad you solved your Adblock issue by switching from Adblock Plus to Adblock Edge.

The Adblock Edge page on addons.mozilla.org says, Adblock Edge is a fork of the Adblock Plus version 2.1.2 extension for blocking advertisements on the web, without sponsored ads whitelist.. The Adblock Plus "whitelist" is described in https://adblockplus.org/en/acceptable-ads

P.S. The problem might have been with your Adblock Plus filter subscriptions or rules since you started fresh with Adblock Edge. If you need help with Adblock Edge in the future, visit the Adblock Edge support site (which links to this wiki) and the Adblock Edge home page.

Modified by AliceWyman