Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Vertical Scroll bar disappears when change zoom level

  • 5 replies
  • 2 have this problem
  • 2304 views
  • آخر ردّ كتبه TylerS

more options

This happens on my website (http://www.gotravelshack.com/), and only in FireFox (not other browsers).

Must refresh page in order to get scroll bar back.

Please help.

Thanks.

Chosen solution

I'm not seeing this happen in Firefox 33.1.1on Linux.

Is there any special script running on the page that deals with resizing elements automatically? (I see some evidence of this)

You can try to disable OMTC (leave hardware acceleration in Firefox enabled).

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


You can reload the web page and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
Read this answer in context 👍 1

All Replies (5)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

No difference in safe mode.

Note: it's only happening on my site, so perhaps it's something I need to fix on my site, but wouldn't know where to start...

Thanks.

more options

Zoom in all the way thru each stage and the scrollbar is there, but I lose it when zooming out at the smallest stage, which is 0.3 (30%) of the original size


See the validation report for your homepage.. http://validator.w3.org/check?uri=http://www.gotravelshack.com/

more options

Chosen Solution

I'm not seeing this happen in Firefox 33.1.1on Linux.

Is there any special script running on the page that deals with resizing elements automatically? (I see some evidence of this)

You can try to disable OMTC (leave hardware acceleration in Firefox enabled).

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


You can reload the web page and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
more options

I opened up my site in a Private Window, and I didn't have the issue, so then I remove all the cookies for the site, and the issue appears gone in my normal window. Not sure what caused it, and hopefully it doesn't come back, but the issue is fixed for now.

Thank you!