X
Tap here to go to the mobile version of the site.

منتدى الدعم

I use dualscreens, whenever I choose fullscreen on Youtube/twitch/... it always go fullscreen on my main monito,anyway to make it fullscreen on other instead?

Posted

I have 2 monitors:A and B My setup: work on monitor A (primary one), put firefox browser on monitor B. What I need: I need to play fullscreen on twitch.tv/youtube/... on monitor B (it always go fullscreen on A whenever I try, even though I putted firefox on B)

I have 2 monitors:A and B My setup: work on monitor A (primary one), put firefox browser on monitor B. What I need: I need to play fullscreen on twitch.tv/youtube/... on monitor B (it always go fullscreen on A whenever I try, even though I putted firefox on B)

Chosen solution

Try this:

  1. Close Firefox and start a new session
  2. Open Firefox on the second monitor and change the window size
  3. Close Firefox
  4. Open Firefox and it should open in the second monitor, from here please try to select full screen for one of the multimedia sites.
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 15.0 r0
  • VLC media player Web Plugin 2.1.3
  • Foxit Reader Plug-In For Firefox and Netscape
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • Firefox 33.1.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.1.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • IDM CC 7.3.85 (mozilla_cc@internetdownloadmanager.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17514
  • driverDate: 9-26-2012
  • driverDate2:
  • driverVersion: 9.17.10.2867
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 942080
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141113143407
  • browser.startup.homepage_override.buildID: 20141113143407
  • browser.startup.homepage_override.mstone: 33.1.1
  • extensions.lastAppVersion: 33.1.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • media.gmp-gmpopenh264.lastUpdate: 1416877354
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1416877354
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1416877431
  • places.history.expiration.transient_current_max_pages: 104714
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1416877430

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4224 solutions 58965 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.
guigs 1072 solutions 11697 answers

Chosen Solution

Try this:

  1. Close Firefox and start a new session
  2. Open Firefox on the second monitor and change the window size
  3. Close Firefox
  4. Open Firefox and it should open in the second monitor, from here please try to select full screen for one of the multimedia sites.
Try this: # Close Firefox and start a new session # Open Firefox on the second monitor and change the window size # Close Firefox # Open Firefox and it should open in the second monitor, from here please try to select full screen for one of the multimedia sites.

Question owner

confirm that my first firefox window have to be on 2nd screen for it to go fullscreen on 2nd screen. thank guig2 for your help :D

confirm that my first firefox window have to be on 2nd screen for it to go fullscreen on 2nd screen. thank guig2 for your help :D