X
Tap here to go to the mobile version of the site.

منتدى الدعم

No text on some websites in Firefox

Posted

Some websites display no text at all. This is unlike earlier reports (e.g. https://support.mozilla.org/en-US/questions/1011611?esab=a&as=aaq) where there was some text. There is also no text in the tabs, menu bar or search box.

I am on Windows, and everything was fine before the Firefox update.

I have tried disabling and reenabling hardware acceleration. Other programs are handling fonts without issue.

This reminds me of a bug I reported back with Firefox 4, I think, where there were issues with font formats. However, as far as I can make out, it’s OpenType and TrueType fonts that aren’t appearing, whereas that time it was an issue with Postscript Type 1.

One of the sites with no text is Facebook.

This appears to be happening only on Windows, not on Mac. I haven’t checked on Ubuntu yet.

Some websites display no text at all. This is unlike earlier reports (e.g. https://support.mozilla.org/en-US/questions/1011611?esab=a&as=aaq) where there was some text. There is also no text in the tabs, menu bar or search box. I am on Windows, and everything was fine before the Firefox update. I have tried disabling and reenabling hardware acceleration. Other programs are handling fonts without issue. This reminds me of a bug I reported back with Firefox 4, I think, where there were issues with font formats. However, as far as I can make out, it’s OpenType and TrueType fonts that aren’t appearing, whereas that time it was an issue with Postscript Type 1. One of the sites with no text is Facebook. This appears to be happening only on Windows, not on Mac. I haven’t checked on Ubuntu yet.

Chosen solution

Cor-el, it took hours of editing fonts, restarting the computer, deleting profiles, installing and reinstalling Cyberfox (a 64-bit version of Firefox), looking at gfx settings, but the solution is this:

turn on hardware acceleration, restart your browser.

I must have turned it off a while back after reading some advice somewhere, so when Firefox went to v. 32, it kept that preference and nuked my text. After turning it back on (not easy, as the Firefox menus and options displayed no text!), the text came back.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 15.0 r0
  • McAfee MSC FF plugin DLL
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • VLC media player Web Plugin 2.1.3
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.30514.0
  • McAfee Virtual Technician plugin
  • iTunes Detector Plug-in
  • Citrix Online App Detector Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • NPWLPG
  • PDF-XChange Viewer Netscape Gecko Plugin

Application

  • Firefox 33.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.0.2/WINNT/en-US/

Extensions

  • Alexa Sparky 1.8.0 (toolbar@alexa.com)
  • Easy Screenshot 1.2.3 (easyscreenshot@mozillaonline.com)
  • Firefox Old Version Update Hotfix 20140527.01.3 (firefox-hotfix@mozilla.org)
  • Flash and Video Download 1.63 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Modify Headers 0.7.1.1 ({b749fc7c-e949-447f-926c-3f4eed6accfe})
  • Navigational Sounds 1.2.4 ({d84a846d-f7cb-4187-a408-b171020e8940})
  • ReloadEvery 28.0.2 ({888d99e7-e8b5-46a3-851e-1ec45da1e644})
  • Super Start 7.3.1 (superstart@enjoyfreeware.org)
  • The Addon Bar (restored) 3.2 (the-addon-bar@GeekInTraining-GiT)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Easy YouTube Video Downloader 7.0 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b}) (Inactive)
  • Hola Better Internet 1.5.154 (jid1-4P0kohSJxU1qGg@jetpack) (Inactive)
  • McAfee SiteAdvisor 3.7.1 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 550 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1244
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 9-13-2014
  • driverDate2:
  • driverVersion: 9.18.13.4411
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 550 Ti Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 4
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141027150301
  • browser.startup.homepage: http://jyanet.com
  • browser.startup.homepage_override.buildID: 20141027150301
  • browser.startup.homepage_override.mstone: 33.0.2
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 33.0.2
  • font.internaluseonly.changed: False
  • font.name.monospace.x-western: Courier Prime
  • font.name.sans-serif.x-western: Lucire 1
  • font.name.serif.x-western: News Plantin MT
  • font.size.fixed.x-western: 12
  • gfx.direct2d.disabled: True
  • layers.acceleration.disabled: True
  • media.gmp-gmpopenh264.lastUpdate: 1414704142
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1414704137
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1414627378
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.cookies: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1413594721

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160039 answers

Is the text there, but only not visible (can you copy and paste the text elsewhere)?

This can be a problem with the font that is used to display the text.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
Is the text there, but only not visible (can you copy and paste the text elsewhere)? This can be a problem with the font that is used to display the text. You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 You can try different default fonts and temporarily disable website fonts to test the selected default font. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"

Helpful Reply

Hi Cor-el: thanks again! You are always on the ball.

The text is there, but not visible.

The fonts aren’t corrupted, but I have narrowed it down to an incompatibility in Firefox with PostScript Type 1 with your Danish link for some of the pages that I remember. They are the ones displaying in my default. It doesn’t quite explain the bug on Facebook but we are one step closer.

I realize PS1 fonts are obsolete but I had expected there to be backwards compatibility as there had been before.

This was a known issue in Firefox many years ago that was originally fixed (in Bugzilla), but it appears it has been broken again with the update. I’ll update the Bugzilla thread as it might help the developers.

Hi Cor-el: thanks again! You are always on the ball. The text is there, but not visible. The fonts aren’t corrupted, but I have narrowed it down to an incompatibility in Firefox with PostScript Type 1 with your Danish link for some of the pages that I remember. They are the ones displaying in my default. It doesn’t quite explain the bug on Facebook but we are one step closer. I realize PS1 fonts are obsolete but I had expected there to be backwards compatibility as there had been before. This was a known issue in Firefox many years ago that was originally fixed ([http://example.com in Bugzilla]), but it appears it has been broken again with the update. I’ll update the Bugzilla thread as it might help the developers.

Chosen Solution

Cor-el, it took hours of editing fonts, restarting the computer, deleting profiles, installing and reinstalling Cyberfox (a 64-bit version of Firefox), looking at gfx settings, but the solution is this:

turn on hardware acceleration, restart your browser.

I must have turned it off a while back after reading some advice somewhere, so when Firefox went to v. 32, it kept that preference and nuked my text. After turning it back on (not easy, as the Firefox menus and options displayed no text!), the text came back.

Cor-el, it took hours of editing fonts, restarting the computer, deleting profiles, installing and reinstalling Cyberfox (a 64-bit version of Firefox), looking at gfx settings, but the solution is this: turn on hardware acceleration, restart your browser. I must have turned it off a while back after reading some advice somewhere, so when Firefox went to v. 32, it kept that preference and nuked my text. After turning it back on (not easy, as the Firefox menus and options displayed no text!), the text came back.
cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160039 answers

It would still be worth to do a font check to see if they are all working OK. With hardware acceleration enabled Firefox may be using a different font.

You can do a font test to see if you can identify corrupted font(s).

It would still be worth to do a font check to see if they are all working OK. With hardware acceleration enabled Firefox may be using a different font. You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1

Question owner

Thanks, Cor-el. Firefox definitely isn’t displaying in a different font with hardware acceleration turned on. But it does have a problem with PostScript Type 1, which was something developers accidentally broke back in 2011 and was eventually fixed. It appears that same thing was broken again and may have affected the few people who choose to use legacy fonts which work with almost every other program in Windows.

I’ve found the test on that page has some issues detecting non-corrupt, multiple-weight fonts that are not PostScript (e.g. Open Sans), but they’re not the culprit here as they are not set to be used in my Firefox.

Thanks, Cor-el. Firefox definitely isn’t displaying in a different font with hardware acceleration turned on. But it does have a problem with PostScript Type 1, which was something developers accidentally broke back in 2011 and was eventually fixed. It appears that same thing was broken again and may have affected the few people who choose to use legacy fonts which work with almost every other program in Windows. I’ve found the test on that page has some issues detecting non-corrupt, multiple-weight fonts that are not PostScript (e.g. Open Sans), but they’re not the culprit here as they are not set to be used in my Firefox.

Modified by Jack Yan