ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Sync has stopped working: Wrong Recovery Key

  • 9 ردود
  • 2 have this problem
  • 27 views
  • آخر ردّ كتبه pbhj

more options

I use firefox sync, it was going ok for months (since I started using it anyway - when FF got that new interface), now suddenly I keep seeing an error message about a "Wrong Recovery Key".

How can I fix this problem, I have done nothing to change any key. Why has it suddenly stopped working?

Modified by NoahSUMO

الحل المُختار

Hey Coxy!

I got a answer. :) You are not the only one to have seen this error.

Reply from Sync developer: We've seen occasional instances of this in the past; things they can try in increasing order of brutality: 1) Disconnect from sync and re-connect 2) Go through the password reset flow on their FxA account 3) Delete and re-create their FxA account Hopefully the first will resolve it.

For the first one, you will need to go into the Sync preferences area of Firefox and click a "Disconnect" button. Then I believe the button will change to "Connect" or "Reconnect". Maybe wait a minute after disconnecting to give Sync time to do it properly then press the connect/reconnect button.

Let me know whatever ends up fixing the problem for you.

Read this answer in context 👍 1

All Replies (9)

more options

Firefox 29 + versions don't use a Recovery Key, that was a feature of the older version of Sync which was used in Firefox 28 and prior versions.

Please provide a screenshot of that message.

https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem

It is best to use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed a maximum file size of 1 MB.
Then use the Browse .... button below the Post a Reply text box to upload the screenshot.
more options

Here is the screenshot.

PS: I think you should put a link to this page in the email I get telling me about replies, there is no link, just buttons to say my problem is solved or not, which in my case, neither applies. I need to reply and I can't. I had to find the page in my browser history.

Thanks for the help.

Do you need anything else to help me fix this problem?

more options

Hey Coxy

I agree with what you said about the thread emails. I find it very annoying myself! I'm working on getting that fixed. :) Sorry for the difficulty.

Thanks for the screenshot! I manually translated it and it reads: Error during synchronization: incorrect/wrong recovery keys. Sync will automatically again to try this action.

Yes, we need your sync log to help you fix this problem. I've shown that error to the Sync developers but they need your sync log to figure out the problem. Type about:sync-log into the url bar and press enter. Then copy and paste everything there into http://pastebin.com and paste the link back here.

more options

http://pastebin.com/jXLJL8TE

Here is the contents of the latest dated text file (error-1412335744203.txt)

about:sync-log shows me about 30 files. hope you don't need them all!

They are al about 4K in size except for this one, which is 11KB, so I added it too.

http://pastebin.com/uE0Vaxr8

more options

Thanks! We only needed the latest one. :)

Hopefully I will get a response from the Sync devs tomorrow or on Monday.

more options

Hi,

any news yet?

more options

الحل المُختار

Hey Coxy!

I got a answer. :) You are not the only one to have seen this error.

Reply from Sync developer: We've seen occasional instances of this in the past; things they can try in increasing order of brutality: 1) Disconnect from sync and re-connect 2) Go through the password reset flow on their FxA account 3) Delete and re-create their FxA account Hopefully the first will resolve it.

For the first one, you will need to go into the Sync preferences area of Firefox and click a "Disconnect" button. Then I believe the button will change to "Connect" or "Reconnect". Maybe wait a minute after disconnecting to give Sync time to do it properly then press the connect/reconnect button.

Let me know whatever ends up fixing the problem for you.

more options

It seems fixed... I disconnected yesterday and then reconnected.

but I think it somehow fixed itself the day before as I had tried clicking on sync and the message never appeared.

Thanks for the help.

more options

I have the same issue, http://pastebin.com/M2G8ReuN, appears to be the point at which things went wrong.

The error line I'm getting is "Sync Key Bundle not set. Invalid Sync Key?".

I don't have a "disconnect" button in the sync preferences [FF33.0 on Kubuntu] only an anchored "unlink", is that what is meant?