ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 5 ردود
  • 11 have this problem
  • 9496 views
  • آخر ردّ كتبه Xena_b

more options

bp-e8de2883-4fd4-45be-b0c3-a8ab02140924 9/25/2014 12:35 AM bp-06827a67-7441-4124-a9e3-43d612140924 9/24/2014 10:42 PM

الحل المُختار

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 👍 0

All Replies (5)

more options

We are really sorry that your firefox crashed ..

Reset Firefox - easily fix most problems.

or,

You can check for problems with current Shockwave Flash plugin versions and try this:

check for updates for your graphics drive drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) disable hardware acceleration in the Flash plugin See also:

http://kb.mozillazine.org/Flash#Troubleshooting

If any problem report us .

more options

I have a Windows 7, 32-bit machine. Firefox keeps crashing. I have the above two crash reports. I have tried some solutions which were given by experts like Turning off USE Hardware Acceleration. And i dont have any bug reports to uninstall. And it also hangs some time until i dont close it forcefully in task manager..

more options

الحل المُختار

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thank You Riyad and Debapriya for your kind help.

I have updated windows and i am not facing any Crashing and hanging report. Thank You Riyad.

Just Click alt or F10' - click on Tools - Click on options - Select general and Uncheck' use hardware acceleration when available.

If the crash is occuring again, then dont change the above options.

Go for start menu (ie; the windows tab) - All programs - click on windows update - click the update option and wait until it finishes the search - click on optional updates which are available on the panel - click optional and search updates with your graphics card manufacturer name ie; intel or AMD/ATI or ..... If you find then check the latest one and click OK - click install updates

Restart Your Computer

Start Firefox

Thank You....

more options

Since yesterday my Firefox started hanging with CPU consuming at 99-106%. I noticed it happened since the new update. Before it was working fine with many tabs open. Followed all tricks mentioned above, didn't solve anything. So then run Apple Software update. Now it is working fine.