ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox seems to be blocking links to external applications, in this case Outlook. Can you help?

  • 2 (ردّان اثنان)
  • 2 have this problem
  • 425 views
  • آخر ردّ كتبه kazlawrence

more options

When I click on the link (eg. mailto;email@domain) in a website nothing happens. If i use Chrome or Explorer the link opens Outlook to send the mail. A friend said 'Must be something to do with the way your browser is setup, maybe blocking links to external applications (outlook etc)' is this correct and how do i fix it please?

الحل المُختار

Perfect - thank you so much!

Read this answer in context 👍 0

All Replies (2)

more options

1. Click the menu button. 2. Click "Options". 3. In the window that opens, click "Applications". 4. Find "mailto" in the list. 5. Set the action to "Always ask".

Then, when you click on a "mailto" link, you should be asked what to do, like in this screenshot. For instance, you can choose Outlook.

Does it help?

more options

الحل المُختار

Perfect - thank you so much!