ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

url does not show up in address bar...and when i type in a search box, the cursor jumps up to the address bar automatically

  • 2 (ردّان اثنان)
  • 3 have this problem
  • 32 views
  • آخر ردّ كتبه the-edmeister

more options

I'm not sure what happened. However, I can never see the URL in the address bar anymore. I go from page to page, and the URL shows only for a split second, then disappers. All the address bar says is "Search or enter address"

I copy and paste a lot of URL links for work, so this makes it very painful and a hassle now. Where now i need to go back, right click on a link, and do "copy link location". Where as i used to just go up to the address bar and copy the URL.

Also, I notice now when I start typing on certain search boxes. The cursor automatically jumps to the URL address bar as soon as I start typing. Which is really annoying.

It will only do it once it seems....but its annoying when i try to type a search...only to see that i've been typing in the URL address box cus it jumped up there.

PLEASE HELP!!!!

I'm not sure what happened. However, I can never see the URL in the address bar anymore. I go from page to page, and the URL shows only for a split second, then disappers. All the address bar says is "Search or enter address" I copy and paste a lot of URL links for work, so this makes it very painful and a hassle now. Where now i need to go back, right click on a link, and do "copy link location". Where as i used to just go up to the address bar and copy the URL. Also, I notice now when I start typing on certain search boxes. The cursor automatically jumps to the URL address bar as soon as I start typing. Which is really annoying. It will only do it once it seems....but its annoying when i try to type a search...only to see that i've been typing in the URL address box cus it jumped up there. PLEASE HELP!!!!

All Replies (2)

more options

Can you attach a screenshot?

more options

Try some basic troubleshooting.


Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.