ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get a message asking me if I want to change my default search engine to Yahoo! Search each time I open Firefox. How do I disable this annoying message?

  • 6 ردود
  • 11 have this problem
  • 13486 views
  • آخر ردّ كتبه NelsonW

more options

For the past few days, each time I open Firefox on my home computer, a popup message is briefly displayed: "Your browser's default search engine is not set to Yahoo! Search. Would you like to set it now? (Yes/No)". After perhaps 15 seconds at most, the popup disappears and my home page appears as normal. I have the Yahoo! Toolbar installed, and Yahoo! Search is the search engine there; however, the search box on the address bar (which allows me to select from several search engines) is normally set to Google. The search engine in the address bar hasn't actually been changed to Yahoo! Search without my consent yet -- I'm just annoyed at getting nagged to change search engines every time I open Firefox. How do I get the "nag" messages to shut up & leave me alone? I would also note that this is only happening on my home computer (which runs Windows 7), not on my work computer (which runs Windows XP, and which I also normally use Firefox as my browser on, with the same Yahoo! Toolbar + Google search in the address bar setup). I have run Threat Scans with Malwarebytes (paid version) and a Quick Scan with Avast! (free version), and neither has eliminated this "nag" message from Yahoo! Search.

الحل المُختار

Go to Tools > Add-ons > Extensions and select the Options button on the Yahoo! Toolbar object. Unselect (uncheck) the "Enable Feature Tips" box. Click the [ I’m Done ] button. No more nagging on my Firefox 31.0 :)

Read this answer in context 👍 7

All Replies (6)

more options

You can check for recently installed suspicious or unknown extensions.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

After following the suggested steps above for "Safe Mode" and "Troubleshooting extensions and themes", I discovered that it was the Yahoo Toolbar extension which was triggering the "nag" pop-ups to make Yahoo! Search my default search engine in the search box in the address bar. I wish I could find an alternative to Yahoo Toolbar, though. I do like how it gives me 1-click access to my most-frequently-visited web pages (f.ex., Yahoo Mail, Facebook, Ravelry, YouTube, etc.) -- I just don't like it nagging me to make Yahoo! Search my default search engine. I see that Yahoo Toolbar has fairly mediocre-to-poor reviews among Firefox users -- what are the best alternatives?

more options

الحل المُختار

Go to Tools > Add-ons > Extensions and select the Options button on the Yahoo! Toolbar object. Unselect (uncheck) the "Enable Feature Tips" box. Click the [ I’m Done ] button. No more nagging on my Firefox 31.0 :)

more options

That did it! After doing as you suggested, I closed Firefox, then reopened it, and the nag message was gone -- hurrah! Thank you so much!

more options

The chosen solution worked for me, too, but I wish Firefox and/or Yahoo would change the ANNOYING default. I was ready to just delete the entire toolbar.

more options

I guess Firefox has their reasons to not exempt this common issue from the fray, just as they refuse to fix the "Java Deployment Toolkit (click-to-play)" plugin warning issue that has been "fixed" for well over a year. According to my contacts with their developers, they apparently feel in is not worth their attention to correct these annoyances.