X
Tap here to go to the mobile version of the site.

منتدى الدعم

Flash player plugin SLOW, uses alot of CPU time

Posted

I am having a problem with Firefox versions 29 and 30. My browser gets very very slow, stalls, scroll bars don't work etc. when I visit sites that host flash videos.

I get two instances of the flashplayerplugin_14_0_0_125.exe *32 running and one of the instances takes as much as 30% of the cpu time.

Sometimes I get a popup dialog box that says "Shockwave may be busy....."

I have tried disabling hardware accel in the plugin, but no difference. I upgraded firefox from 29 to 30, no difference.

I tried running Firefox in safe mode and then enabling Flash when trying to view a video - no difference

Flash works just fine and uses almost no CPU time in Internet Explorer 8


My system is Windows 7 64 bit home edition

I am having a problem with Firefox versions 29 and 30. My browser gets very very slow, stalls, scroll bars don't work etc. when I visit sites that host flash videos. I get two instances of the flashplayerplugin_14_0_0_125.exe *32 running and one of the instances takes as much as 30% of the cpu time. Sometimes I get a popup dialog box that says "Shockwave may be busy....." I have tried disabling hardware accel in the plugin, but no difference. I upgraded firefox from 29 to 30, no difference. I tried running Firefox in safe mode and then enabling Flash when trying to view a video - no difference Flash works just fine and uses almost no CPU time in Internet Explorer 8 My system is Windows 7 64 bit home edition

Additional System Details

Installed Plug-ins

  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Shockwave Flash 14.0 r0
  • This plug-in enables downloading of HTML5 videos
  • This plug-in enables downloading of Flash videos
  • This plug-in enables downloading with the Download This Video button
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Garmin Communicator Plug-In 4.1.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0

More Information

FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

Hello,

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Hello, Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

Helpful Reply

From my original submission:

I have tried disabling hardware accel in the plugin, but no difference.


I don't know what to do. Firefox is practically unusable with Flash

From my original submission: I have tried disabling hardware accel in the plugin, but no difference. I don't know what to do. Firefox is practically unusable with Flash
FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Press the '''<Alt>''' or '''<F10>''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites and see if there is still a problem. Then restart