ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My new tab page is missing and now when I type about:newtab in the Awesome bar I get a page called about:about. Help!!

  • 6 ردود
  • 3 have this problem
  • 15 views
  • آخر ردّ كتبه cor-el

more options

I use to have the grid of pinned webpages whenever I clicked on the X of a new tab page. Now it's gone. I figured out if I typed about:newtab in the Awesome bar it would restore the page, but not all the time. Now when I type about:newtab in the Awesome bar I get a page called about:about...and I don't want that. How can I get my pinned websites back on my New tab page?

I use to have the grid of pinned webpages whenever I clicked on the X of a new tab page. Now it's gone. I figured out if I typed about:newtab in the Awesome bar it would restore the page, but not all the time. Now when I type about:newtab in the Awesome bar I get a page called about:about...and I don't want that. How can I get my pinned websites back on my New tab page?

الحل المُختار

Open a new window or tab. In the address bar, type about:config. If a warning screen comes up, press the Be Careful button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar. Enter browser.newtab.url and press enter. browser.newtab.url tells Firefox what to show when a new tab is opened. If you want, right click and select Modify. You can change the setting to;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

The same instructions are used for the new window setting, listed as browser.startup.homepage.

Read this answer in context 👍 1

All Replies (6)

more options

الحل المُختار

Open a new window or tab. In the address bar, type about:config. If a warning screen comes up, press the Be Careful button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar. Enter browser.newtab.url and press enter. browser.newtab.url tells Firefox what to show when a new tab is opened. If you want, right click and select Modify. You can change the setting to;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

The same instructions are used for the new window setting, listed as browser.startup.homepage.

more options

See also this article about the New Tab page (about:newtab):

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Yes, I get that. However after I shut down Firefox and then restart it again it loses it's new settings and all I get is a blank page. One guy was having the same problem in reverse. He wanted it not to show the home page in every new tab - I do. I'll try again using about:home and not use the URL. Maybe that will work.

more options

Well, I went to config:about, pressed the warning button, typed about:newtab, got the item about a new URL and then changed it to a new address. It worked while I kept Firefox running. I shuut it down and restarted it again and I was back to square one.

Does it have a problem with https?

more options
more options

If you do not keep changes after a restart or otherwise have problems with preferences, see:

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.