ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open links from email

  • 11 ردًا
  • 25 have this problem
  • 7036 views
  • آخر ردّ كتبه FredMcD

more options

I'm using Firefox 29 on Win7x64. It's my default browser. Sometimes, when I try to open a web link from Outlook email or Yahoo email, the link does not open. Instead, Firefox opens a process every time that I click, but does not open the link or even a page. If I try to open another Firefox instance by clicking the shortcut, yet another process starts, but a page does not open. Safe mode does not help. The only resolution thus far is to close every process or reboot, and then re-install Firefox. This issue began in v29 or the one just before. I also have tried suggestions posted to the forum. Thanks!

الحل المُختار

Note that Firefox 30 will be released officially this Tuesday, so best is to install that release version once available to avoid getting updates to Firefox 31 because installing a beta will put you on the Beta update channel.

Read this answer in context 👍 1

All Replies (11)

more options

You can try this, go to one of your other web browsers. Go to its options, and have it declared as the default browser. After you close the browser, open Firefox. Then have FF become the default browser. If it works or not, let us know.

LAST RESORT ! ! Reset Firefox {web link}

more options

I've tried this several times. It works for a while, but the issue recurs. Resting Firefox never is a good solution for any Firefox issue.

more options

What is why I said; LAST RESORT

more options

Resetting Firefox can be good for hijacked browsers, extensions that can't be removed manually and other issues, but it's not the solution to everything.

  when I try to open a web link from Outlook email or Yahoo email, the link does not open. Instead, Firefox opens a process every time that I click, but does not open the link or even a page. 

When you say Firefox opens a "process" everytime you click does it open a new Firefox window or something else? Check your settings to see if it's configured properly. New windows are opened in a new tab by default

  • new fx menu -> Options -> Tabs -> check mark "Open new windows in a new tab instead"
more options

Thanks. I always have unchecked the option to open new windows in a new tab. By process, I mean that the executable is loaded in RAM, but Firefox does not open. I can see the processes in task manager. Once the processes stack up, I can't even open a new instance of Firefox from the desktop shortcut.

more options

Oh, I understand now.

This is a current bug in Firefox but the problem is probably already solved in Firefox 30b8. Others have reported that they no longer see the issue

Note if you do install the Beta do NOT use any option to remove personal information or you will destroy bookmarks and passwords etc. If you install the Beta you may do that over the top of the ordinary Fx29.0.n Release. No need even to uninstall Fx29 first.

One of the devs who worked on the bug had this to say:

Note I'm one of the devs who fixed the issue. We believe that the issue has been fixed in Firefox 30 beta 8. If you are affected by the issue, you may download this version here: https://www.mozilla.org/en-US/firefox/channel/ or wait a few weeks until it comes out of beta. This bug was triggered by cleanup of thumbnails during shutdown. In most runs of Firefox, this cleanup worked nicely. However, a combination of circumstances could cause the cleanup mechanism to start loading its resources during shutdown, after the loading mechanism had already shutdown itself. Firefox waited until that load was complete to proceed with shutdown, but the load could not complete. Two fixes have been landed. A fix specific to thumbnails landed in time for Firefox Beta 8 and ensures that we never shutdown the loading mechanism before the cleanup has had a chance to complete. A more general fix will has landed shortly after to ensure that the bug does not reappear with other subsystems. You may find all the technical data on the bug and how it was resolved here. As a side-note, this issue is not considered a security bug, as it may only be triggered by sitting in front of the computer and changing the settings. We reserve the denomination for security bugs for issues that can be triggered without the consent of the user.
more options

Great! I just installed the beta and will let you know how it goes.

more options

Moses, the beta appears to have solved the issue. Thanks again!

more options

الحل المُختار

Note that Firefox 30 will be released officially this Tuesday, so best is to install that release version once available to avoid getting updates to Firefox 31 because installing a beta will put you on the Beta update channel.

more options

I'm having the same or a related problem on Mac OSX 10.9.4 with Firefox 32.0.3. When I click on a link in Thunderbird email, if Firefox is hidden, it re-displays the Firefox window but does not open a new tab - only the previous content is displayed. If I then click on the link again, it does open a new tab as expected. This is new behavior which I suspect began with the last Firefox update. The date on the Firefox file in Applications is 9-26-14 which seems about the right time frame for this bug.

I normally use the Hide feature (apl H) instead of minimize. If Firefox is minimized, the first click on a link does not appear to do anything, but the second click does cause Firefox to reappear and a new tab to open correctly.

more options

mopep

Type about:preferences<Enter> in the address bar

Select General. Look for Tabs. Turn off Open new windows in a new tab instead