ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFox 29.0.1 is sluggest to non-responsive

  • 3 ردود
  • 1 has this problem
  • 1 view
  • آخر ردّ كتبه Patrick

more options

I am running Windows XP plus the two service Packs and have the RAM maxed out. The hard disk has at least 60% space available.

I have several malware bug programs who have reported my system is clean. The hard disk has been defragged. When this version of FF was installed, it accepted all plugins except Forecastfox 2.2.2.

Firefox is slow to respond to a click on a web site using 10 or more seconds to even show in the tab that it is "Connecting." When "Connecting" in a tab appears it then takes much more that 10 seconds before the web page is displayed. When writing this report as well as other writing on some other web page, there is a pause when the space bar is pressed. Trying to go back a page has the same slowness of many seconds.

I'm tired of this. If it is not being fixed, can I roll back to the previous version of FF that worked so well?

الحل المُختار

Is this with some web pages, many all?

Many site issues can be caused by corrupt cookies or cache.

Clear the Cache
Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

Remove Cookies
Firefox/Tools > Options > Privacy.
Under History, select Firefox will Use Custom Settings.
There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration.
Poke around safe web sites and see if there is still a problem. Then restart.

Read this answer in context 👍 1

All Replies (3)

more options

الحل المُختار

Is this with some web pages, many all?

Many site issues can be caused by corrupt cookies or cache.

Clear the Cache
Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

Remove Cookies
Firefox/Tools > Options > Privacy.
Under History, select Firefox will Use Custom Settings.
There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration.
Poke around safe web sites and see if there is still a problem. Then restart.

more options

Thanks for your reply.

I usually do clean out Clean all History, Browsing & Download, Forms, Cookies, Cache. I did so before going into Safe Mode.

I then looked around some of my various news web sites. The response time was the same slowness. The back up a page was equally sluggest.

Then I went to Safe Mode and found and unchecked the HARDWARE Acceleration box. I then looked at a few more web sites with the same slowness.

I quit Safe Mode and tried some more web sites and it's still the same thing: slow to sluggest opening a new location, opening a link on that page and backing up to the main page.

more options

Well, I think it's fixed now.

After trying FF after your suggestions and not getting improvements, I removed all my Add-on's. Then I ran both of my bug search programs, with nothing found, followed by a complete defrag. Then I put back my Add-on's.

My FF, so far, is looking and acting like the previous version.

Thanks.

I'll call this problem solved.