On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Shopify page doesn't load anymore

more options

Hi I have a Shopify account and since the Firefox 99 update my Shopify shop page doesn't load any more, showing an error message. I have had to download Chrome in order to access my shop - really annoying. Have anyone been able to troubleshoot the problem? I find it really affects my ability to do business and I am feeling let down by Firefox. I am adding a screenshot of the error message. I can access my shop without any trouble on Edge or Opera browsers. Firefox is the only one having issue...

Hi I have a Shopify account and since the Firefox 99 update my Shopify shop page doesn't load any more, showing an error message. I have had to download Chrome in order to access my shop - really annoying. Have anyone been able to troubleshoot the problem? I find it really affects my ability to do business and I am feeling let down by Firefox. I am adding a screenshot of the error message. I can access my shop without any trouble on Edge or Opera browsers. Firefox is the only one having issue...
Aangehegde skermkiekies

All Replies (6)

more options

Hi Cat, do you know whether the part on the left and the part on the right have different "origins"? The origin is the protocol + host name. As an example of different origins:

https://www.mozilla.org/ vs. https://support.mozilla.org

Firefox has progressively restricted what data passes between different origins, so every time there's an uptick in privacy, users report some unexpected site breakage.

To check the origin, right-click the area on the right and look for "This Frame" on the menu. If you find that, expand it and click View Frame Info to check the address. If you compare with the address bar, is it a different origin?

Helpful?

more options

Hi Josh thanks for your reply. I can't see "this frame" in my menu when I right click but if i do "inspect" i have all the code appear... I can't locate the name of the frames though... It looks to me that is all in one page but at different points in the code... I'm not sure it makes sense? (sorry can't screen shot for some reason)

Helpful?

more options

However I can see an error message under the code saying this:

Cookie “admin_react_internal_enabled” does not have a proper “SameSite” attribute value. Soon, cookies without the “SameSite” attribute or with an invalid value will be treated as “Lax”. This means that the cookie will no longer be sent in third-party contexts. If your application depends on this cookie being available in such contexts, please add the “SameSite=None“ attribute to it. To know more about the “SameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite

Helpful?

more options

It's a long story, but Firefox started enforcing stricter rules for SameSite cookies a few versions ago and many sites weren't ready, so Firefox went back to only providing a message for developers in the console. You can double-check that your Firefox isn't enforcing the stricter rule this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are checking that the setting is the default, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

(3) If the network.cookie.sameSite.laxByDefault preference is bolded and has a value of true, double-click it to restore the default value of false

Helpful?

more options

Hi thanks for this. I checked and the network.cookie.sameSite.laxByDefault is on false. but not bolded. under it is network.cookie.sameSite.laxByDefault.disabledHost with no value

and under a line, in bold: laxByDefault with 3 options: boolean number string and a plus at the end of the line.

(I feel I am learning a foreign language here!! ;-) ) Can't screen shot...

Helpful?

more options

Okay, let's go back to basics. You might already have checked many of these things, but just in case: if a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) The shield icon toward the left end of the address bar usually turns a bit purplish when content is blocked. Click the icon to learn more or make an exception. See: Enhanced Tracking Protection in Firefox for desktop.

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix usually provide a toolbar button to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you sometimes need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe/Troubleshoot Mode: In this mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Helpful?

Vra 'n vraag

Jy moet by jou rekening aanmeld om op plasings te antwoord. Begin asseblief 'n nuwe vraag as jy nog nie 'n rekening het nie.